Pixelated sharp shadows using Area Shadows For Stationary Lights

Hey guys,

I’m trying do to a very thorough breakdown of Unreal Engine 4’s lighting settings and I’ve been encountering some road blocks. One of them is ticking ‘Area Shadows for Stationary Lights’ in a Directional Light. As you can see in the image below, I’ve built light (Production Quality) in both images, the left one is using the ‘Area Shadows’ option, giving me great attenuation of shadow softness, but the problem is that close to the object casting shadow, where the shadows should bee sharper, I am getting this pixelization which is killing me! haha.
To compare, the right image was rendered using the out-of-the-box settings for Directional Light, and it is giving non pixelated sharp shadows.

Both scenes were built using the same Light Building Quality and same lightmap resolution, which means that the lightmap resolution isn’t the issue, correct?

Thanks for your time,