Pathtraced objects always show black unless dynamic shadows turned off

I have imported some objects with the datasmith importer which work fine with materials and lighting in lumen, however whenever the pathtracer is activated only those objects remain black.

The issue seems to be that the objects are self-shadowing because if the dynamic lighting is deactivated on the object, the material shows as normal but then no shadows are cast on the ground.

Any help on this is appreciated or if anyone knows if I have just missed a setting.

did you ever solve this? I’m having the same issue. With ‘Cast Dynamic Shadows’ turned ‘on’, all object are black.