Particle emmiter is not always activating

I completed the collision and components tutorial in the C++ Documentation (Here), and when I activate and then de-activate the particle emmiter, it doesn’t always seem to re-activate. At first I thought that it was tied to mouse focus, but that doesn’t seem to be the case.

I have a particle system component that is tied to a custom pawn, with the autoactivate set to false upon initialization.
I have a Action binding to the space bar, and it simply calls a function that toggles the particle system.

Any Ideas as to why this is happening?
What other info would I need to provide to help with this

Have you print tested at the end of lines to see how far the particle goes before it breaks. Also from what it sounds like a boolean that is set wrongly once its deactivated?.. just throwing my thoughts… it worked for me so not sure where the error is for you…

oh it was 4.9.2 not 4.11 so check debug as the tutorial is for 4.9…

I am having a similar issue. I tried adding a particle effect to the flying pawn, and I know the particle is attached and working because if I set bAutoActivate = true then it starts playing as soon as the scene loads. I tried countless iterations of trying to start/stop it after scene load and it just does not want to turn on and off.

I used the identical syntax that was used for the components tutorial, which worked fine. Countless different iterations of using ToggleActive(), and other related functions will not cause the particle to activate.

Having a similar issue: calling Activate on a particle system in a blueprint graph does not cause it to start.