Paper2D Unlit Sprite Affected by Lighting?

I am noticing some issues where as my paper2D sprite that has “MaskedUnlitSpriteMaterial” texture is darker at the corner of the screen compared to when it is at the middle. Also all my sprites are affected by lighting even though there are using “MaskedUnlitSpriteMaterial”

Things to note:

  1. Sprites are placed in the 3D world

  2. They all have “MaskedUnlitSpriteMaterial”

  3. Camera is orthographic

  4. No lighting/post process in the level

  5. I am using 4.8.3

Here are some comparison images:

  1. My default HUD position located at the top left

  1. I moved the HUD to the center, now it is slightly brighter

  1. Comparison of the shell icon


  1. All my sprite uses “MaskedUnlitSpriteMaterial” but when I set preview mode to lit, everything becomes darker. Unlit preview mode is what I want my game to look like. What is causing “MaskedUnlitSpriteMaterial” to get affected by lighting?

LIT PREVIEW (This is how the game looks when I run it)

UNLIT PREVIEW (I want the game to look like this)

A good way to reproduce this is to find “DefaultSpriteMaterial” under engine and open it. Look at the preview panel, and change lit to unlit, the unlit version will be slighty brighter even though the material shading model is set to unlit.

This has been bugging me for awhile, is there any way to fix it? Thanks!

Hey SmileyJeff,

Thank you for your report. Fortunately, this issue UE-16928 has already been reported and fixed for the official 4.9 engine release. You can simply wait for official release to get the fix for your project. If you would like to test the issue, you can open a copy of your project in 4.9 preview 3 to see if it still occurs.

Let me know what you discover, or if you have any further questions.


Sorry I did not go through the bug list carefully. I will port a copy of my project and test it on 4.9 preview 3. Thank you!

so is this fixed ? it appears ok in the editor when I use unlit option but once the game runs, all sprites arelit althought I have setup an unlit material for my sprites

Has anyone found any solution for this? it still actually happens, I have the exact same problem in UE5