Panoramic Capture in Unreal Engine 5 problem

So I’m trying to do a 360 capture in Unreal 5.0.0. using the Panoramic Capture plugin. I’ve gone through the Unreal tutorials on youtube as well as some tutorials other people have made and checked and double checked that everything is set up properly.

In 4.27.2 is OK

The problem I’m running into is that in the blueprint, at first I tried using the default directory and received this error message:

“The output directory’s drive doesn’t exists. Plese set SP.OutputDir with a valid path. Skipping renders…”

So, I created the default folder on my C drive because it didn’t exist, though I would assume if the plugin was working correctly it would just create it. Tried again and received the same message.

After that, I created a specific folder on my D drive, highlighted it in Explorer and copy/pasted the path into the blueprint where the default had been before. Compiled & Saved. Tried again and still got the same error message.

Is the plugin just not working correctly in UE5.0.0. or am I doing something wrong? Thanks in advance.

1 Like

I had the exact same issue.

Just remove the path part of that string, or remove the OutputDir blueprint node entirely. Then, you’ll get the images in your project folder/Saved/StereoPanorama by default.

There is a problem with the OutputDir string checking inside SceneCapturer.cpp that the devs should look into.

Thanks, I tried this but the problem didn’t go away :frowning:

Then you must still be getting the drive letter in there somehow. The issue is that the code breaks if a drive letter is included.

Try giving this string for the command on the blueprint node:
SP.OutputDir ../../../../../Panorama
and check the log to see if this is the last OutputDir command. Then you should be getting your images somewhere next to your unreal engine folder.

Are you a genius??

It works !!!

Thx

did it work with lumen without seams ?

No for now

Ok, so the command actually works, but I can’t find the 360 renders anywhere. I’ve looked where the engine is installed, and where I’m keeping my project files, but haven’t found any of the render outputs.

Hi

try change …/…/…/…/…/ with …/…/…/ or … try combination


So this is what I get in the Message log and in the output log as well, but I can’t find the path to the files in File Explorer. I’m pretty sure the command gets executed properly, but I can’t confirm with 100% certainty until I locate the files.

I have UE project in C: documents / Unreal Projects /
capture parametars is

SP.OutputDir …/…/…/…/…/Panorama

and in C: in root apperas Panorama and folders with images

I gave up on using UE 5 for the time being because I realized there are many more bugs related to lighting that I just don’t have the time to debug atm. Thank you for your help though, I’ll give it a go again in a few patches.

I’m sorry you’re giving up
for me ue5 is great no problem for now

i think you just need to set the number …/…/ depending on where the UE project is located and it works 100%
i use this plugin on two machines with different settings on different disks

a different configuration was required but only for the number …/…/…/

sorry for my english, i’m from croatia

Dude, how do you manage to make the pictures not go dark? I’ve been trying for a long time and I can’t.