Paint Foliage: don't see texture

I’m painting some grass on my landscape.
I already searched in the forum for an answer but I did not find it.

  • when asked to add foliage type in the Paint Foliage, I added mesh that already has a texture on it.

However, when I paint it, I can see the texture in the viewport, but when i launch the preview of my landscape all my grass are planes without the texture on it (just grey and dark grey squares).

Do you have any idea for how can I solve this problem?

thank you in advance

I’d start with opening up the foliage you are trying to use and make sure it has the proper mesh selected. If that’s all ok I’d check the static mesh itself which the foliage file is based on and make sure it has a material applied to it.

thank you for your answer.
As you can see in the image attached the material is already applied on the mesh that I’m using to create grass.
Also, you can see that in the viewport I can see my grass, but not in the preview.
Can be that some settings in the details view cause this problem?

Hello mate, if you havent found the answer yet i’ve faced a similar problem with applying Materials to landscape segment and was so kind to help me out. After i solved this i found out i was getting the same Tile Effect on one of my foliages. I went to the material applied in the static mesh i used in my foliage, i clicked my texture samples and changed the Sampler Source to Shared:Wrap. This fixed my problem and hopefully it will do the same for you!

Also here’s a link from the exact solution posted for me in case you face another problem like mine in the future. Take care!

1 Like