Packaging error, might be due to Apex Destruction Plugin

Hi I got this error while trying to package.

LogUObjectHash: Compacting FUObjectHashTables data took 2.44ms
LogMainFrame: Project requires temp target (ApexDestruction plugin is enabled)
LogLauncherProfile: Unable to use promoted target - …/…/…/…/…/HAUNTBackup/HAUNT 4.26/Binaries/Win64/ does not exist.
UATHelper: Packaging (Windows (64-bit)): Running AutomationTool…
UATHelper: Packaging (Windows (64-bit)): Parsing command line: -ScriptsForProject=“C:/HAUNTBackup/HAUNT 4.26/HAUNT.uproject” BuildCookRun -nocompileeditor -installed -nop4 -project=“C:/HAUNTBackup/HAUNT 4.26/HAUNT.uproject” -cook -stage -archive -archivedirectory=“C:/HAUNTBackup/HAUNT 4.26/PackageTesting” -package -ue4exe=C:\UE4.26\UE_4.26\Engine\Binaries\Wi
n64\UE4Editor-Cmd.exe -clean -ddc=InstalledDerivedDataBackendGraph -pak -prereqs -nodebuginfo -targetplatform=Win64 -build -target=UE4Game -clientconfig=Development -utf8output
UATHelper: Packaging (Windows (64-bit)): Setting up ProjectParams for C:\HAUNTBackup\HAUNT 4.26\HAUNT.uproject
UATHelper: Packaging (Windows (64-bit)): HAUNT.uproject requires a temporary target.cs to be generated (ApexDestruction plugin is enabled)
UATHelper: Packaging (Windows (64-bit)): ERROR: Unable to find target ‘UE4Game’
UATHelper: Packaging (Windows (64-bit)): (see C:\Users\Administrator\AppData\Roaming\Unreal Engine\AutomationTool\Logs\C+UE4.26+UE_4.26\Log.txt for full exception trace)
PackagingResults: Error: Unable to find target ‘UE4Game’
UATHelper: Packaging (Windows (64-bit)): AutomationTool exiting with ExitCode=1 (Error_Unknown)
UATHelper: Packaging (Windows (64-bit)): BUILD FAILED
PackagingResults: Error: Unknown Error

When I disabled the plugin it seemed to continue packaging but I believe it errored again because it got to my BPs with the destructible meshes. Besides disabling the plugin. Is there something I may be doing wrong that is causing it not to package proper with the Apex Destruction plugin?


Same Here!
Any Progress?

I tried link bellow and it worked for me!

What i think might be happening here is you will notice that apex put’s breaks in meshes so it may have changed the skeletal characteristics some way, so even if you remove the plugin meshes might need to be reconfigured, you could try reloading mesh models again replace files then fix up redirectors.

But since the issue is not locating the file directory you might be missing a step somewhere, i had a similar problem with migrating using plugins for bridges between editors, what was happening when i migrated it was exporting part of the bridge that i had to uncheck so it could find the content folder correctly.
Something like this could be happening when trying to package the project you might need to just tick something on or off in project settings, try looking at the plugin settings in project settings too for options…

Having the same issue after updating a project from 4.27 to 5.2

Very similar message log.

message.txt (10.0 KB)

After disabling the Apex Destruction plugin I can get it to start packaging, but it still fails after a while and complains about missing nodes.

Any idea for how to make the plugin work? Or another solution?

Edit: Suddenly it’s no longer packaging anymore lol.

My output log: LogUObjectHash: Compacting FUObjectHashTables data took 0.59msLogTurnkeySupp -

Can anybody help? This is driving me crazy.

Edit: Got it working: Unknown Package Error UE5.2