Packaging Fails After Transition to 4.26 - ERROR: Unable to find target 'UE4Game'


I’ve been previously able to package my game in Deployment mode for friends to playtest when I was in 4.25.

Today I upgraded to 4.26, but now whenever I try to package my project I get, "ERROR:Unable to find target ‘UE4Game’.

Attached is my log. I’ve been able to get this to work by migrating all of my assets to a brand new project, but that solution won’t work for me as I have my version control all pointing to the current project (and I wouldn’t want to do this every time I upgrade game versions).

Any help would be appreciated, this bug is currently halting my ability to make updates to the pre-alpha work of my game to send out to people to playtest.

Please let me know if any more information is needed, I’m eager to get things back on track.

link text


Just a follow up for a hint to this problem. I get the error that my project requires a temporary target.cs to be generated for each of my plug ins. If I uncheck ALL of my plugins the packaging gets past this stage… but then fails because of all the errors that come up from not having my packaging.

There’s an answer to this problem if someone else is looking at this.

If I make my project a C++ project, it’s able to build from there. You don’t need to know C++ to do this, but you will have to deal with the scariness of dipping your toe into it if you haven’t already.

For anyone who doesn’t know how to do that, do the following.

  • Install the latest version of VisualStudio.
  • In your project, create a new blank C++ class.
  • Close your editor. There should be an .sln file in the same directory where your project is. If not, right click on your project and click on “Generate Visual Studio Project Files”
  • Open the .sln in Visual Studio.
  • Select the project name in Visual Studio. Towards the top beneath “Build” and “Debug”, you can select the type of build you’re doing. DebugGame, Development ,Development Editor etc. Select “Development Editor”
  • Right click on your project and click “build”. This should just take a few seconds.
  • Change the build type to be “Development”
  • Right click on your project again and click on build. This will take a little longer.
  • When the build is done, open your project again. You should be able to package at this point.

I tried this One and it worked like a charm, Mate
Really Appreciate That

It says Severity
Error MSB3073 The command “D:\ue27.2\UE_4.27\Engine\Build\BatchFiles\Build.bat projectrevolrtion2Editor Win64 Development -Project=“F:\backup\mario\backup3\projectrevolrtion\projectrevolrtion2.uproject” -WaitMutex -FromMsBuild” exited with code 6. projectrevolrtion2 D:\vs\MSBuild\Microsoft\VC\v170\Microsoft.MakeFile.Targets 44

also it say unable to create child process