Packaged game crashes on load when Share Material Shader code is turned on

When Share Material Shader Code is turned on in project settings, and the game is packaged, it crashes when run during some async IO operations.

This was fine in previous versions on UE4. It happened after updating the project to 4.18.0. Win64 build.

Hello jimsnomis,

I’m seeing the same result just by packaging with that setting enabled in a Third Person template project. Just to ensure that I am getting the same error as you, is this what you see?


I’ll be testing in 4.17 and our latest build to test for regression and if it happens in our latest build and I’ll enter a bug report after, so I’ll let you know when that happens.

Hey Matthew,

It wasn’t this specifically - but I was running in VS2017 and the debugger caught it. It wasn’t during packaging but running the packaged game though.

Thank for that information. I’ve entered a bug report for the issue here: UE-51705. I was a little unclear in my last comment, I’m getting the crash when launching the packaged game as well. I cannot think of a workaround at the moment other than using 4.17. Please follow that report for updates on the bug’s status.