P_fire troubles

Greatings again.
here to find out about an issue a have with the P_fire dissapearing in some camera positions.

Also ive noticesd that the light, that P_light, and any othe particle light casts, dissapears when im moving far enough form it. As in that room, ive placed some fires. I turn back from the flame, see the light from it on the opposite wall, run to the wall and the light is suddenly out.

The lights are right from the menu, no tweaks. Any ideas?

Hi Vivaldin,

That is caused by the camera leaving the Particle’s bounds. You can scale that up to fit the room better by going into the Details window of the P_Fire instance, then setting the Bounds Scale to a higher number. Let me know if that helps.


You will need to make that a lot higher. The best way to make sure your rendering bounds are the correct size for your lights is to go into your Particle’s editor and compare your “Preview Light Radius” to the set Bounds. Here is what they look like by default:

By clicking off of the module, you will see your Particle System’s details. In that menu, you will find the “Bounds” defaults and you will want to set the “Fixed Relative Bounding Box” to be larger that then Light Radius. That will make it so that the light will not be visible by the time you leave the render area, so there will not be an abrupt light change.

Let me know if you have any questions.

No effect.

It do not disappear when i look on it. If i turn away…

My light radius is gigantic. I cant scroll enought to see it hall in the viewport. Is there a way to lower it?

Ive tried to set “Fixed Relative Bounding Box” to some millions, but it was no use…

If you click on the Light module, you will be able to find the “Radius Scale” variable. If you set that to something lower, it will shrink the radius to something more manageable.

Yey, i did it =)

For the upcomers - in the “Fixed Relative Bounding Box” the lower the bigger. Ive tried to put in 10000 and it shrinked the radius, on which the light goes off. But with -10000 it works nicely.

Thanks to Alexander Paschall =)

Hey Guys,

i have the same issue, with turn off on the light in Particle - P_Fire. It looks like there is a second bounding box, see screenshot. I can not fix it with a big Bounding Box.