Overlapping UV's

So my house model has overlapping UV’s when I render my scene in UE4. Now this is quite suprising since I know how to set up my UV’s (Or I thought I did, haha), but this model is not working although all my other models in the scene are working fine. I used the same method within 3DS max to make the UV’s for my models.
My workflow: Convert to poly → Unwrap UVW → Open UV editor → Flatten mapping (default settings) → Repeat steps for channel 2.
This is the only model that is giving me overlapping UV’s. Here are the screenshots:



Does anyone have experience working with 3DS max and having a similar problem?
I have no idea how to fix this.

Does your lightmap index 1 look the same inside the editor?

If it looks fine then I would suspect your problem is that your lightmap resolution is too low for the many small clusters your model has. if you’re at default res then you have a 64x64 map for the whole UV channel and all those small trim pieces is hardly getting a pixel of data, hence appearing to overlap with its neighbors.

I’d suggest increasing the lightmap resolution for this object and see if you get less % overlap.

I think when it says overlapping it IS overlapping! The lightmap resolution doesn’t count here…

Well, as you can see from the pictures they clearly are not overlapping. that is why it is confusing :stuck_out_tongue:

This makes sense. I will try it out and let you know if it helps :slight_smile:

Well the picture is tiny and I won’t trace back every single face where it is on your lightmap uv BUT if Unreal says it’s overlapping (and you see the result that it’s wrong!!) then it is overlapping!! …maybe you have duplicated/overlapping faces on your mesh…

So I did 3 things:

1: Check the UV within UE4. In UE4 both channel 0 and 1 looked exactly as in the screenshots, and do not seem to be overlapping.
2: Increase the size of the UV: This made no difference. Same percentage of overlap.
3: Check for any duplicate objects and faces. I found none.

So both in UE4 and 3DSmax the UV’s look fine, yet it says it is overlapping regardless of UV size.

I’m sure Unreal doesn’t just make up things to annoy you! :wink: + also you can see on the baked mesh that the lightmap is NOT ok, so for sure there is a problem! :wink:
So it’s not a magical and mysterious thing: your lightmap is wrong!! If the automatic generation is not working: you’ll have to do it manually!!
…or find the problem on your mesh, clean it and then use the auto uv option and I guess there won’t be a problem…

Makigirl, its ok to not know the answer. Its clear you have no idea of a possible solution. Telling someone that something is wrong without offering a basis for correction is just as bad as offering a bad solution. You added nothing to the conversation esp for those like us who actually seek an answer. Nothing you have stated is separate from what he or any of us has done. While there might be a solution, this post has not been helpful at all.

I hope you feel better to come back to this and write your opinion down after a year! :wink: :smiley: