Download

Out of video memory when trying to open one of my levels (which was fine before)

“out of video memory trying to allocate a rendering resource. Make sure your video card has the minimum required memory, try lowering resolution and/or closing other applications that are running.”

So i am upgrading an older project to 4.26… was able to open the level. build lighting… then it crashed at the 100% of build lighting when importing all the lightmaps in. Since then i cant open the level… i am faced with that out of video memory crash…

I have an rtx 3090… so it makes no sense… even incrased paging file to 150 GB… nothing helps… What is going on ?

1 Like

try enabling texture streaming or virtual textures and lightmap vt

Why should i though… it worked ine back in 4.22

Also all 3 of those are already enabled in the settings.

Go into the project settings and temporariliy reduce the resolution of the reflection captures.

Then again, on a 3090 this still doesn’t make much sense…

The only other option is to migrate the level and all the assets to a new project. That should at least get you to open the level…

i can open the level if i put all graphics settings to lowest… but hten building lighting… once it reaches 100% and gets to doing all the refelction captueres… it decides to crash it… with that error. Also reflection capture resolution is only set to 128 :confused:

Can this be a bug with 3090??? I mean… this thing used to build just fine on a 2080TI at an earlier version of unreal.

update to this… it crashes when building reflection captures for the entire level… alone… I literally tried in settings to switch the reflection captures to 64… and it crashed it with that error when it rebuild reflection captures alone…

I actually tried building reflection captures only and it crashes with this error as well.

1 Like

Seems likely. If you still have your 2080ti, an admittedly inconvenient way to know for sure would be to temporarily swap your cards to see if you can build the captures in 4.26.

I am seeing other posts about bugs with rtx 3090… i dont want to go back to 2080ti because of a bug. Aside from that i also crashed it by switching to refelction view and typing r.RayTracing.ForceAllRayTracingEffects 0 … some maybe it has something to do with combination of reflection capture and raytracing features?

I have the same problem on a 6GB GTX 1660 Super, which worked previously also.

If you can open the Group, then Copy everything but the Landscape, after the level is safe and saved with the group in place, create a new level, paste the contents of your copy to the level, save that one and try opening the level you opened that crashed, delete the pasted actors and use the landscape, (you likely want the foliage i assume) but copying a landscape should work it simply might now paste in the Layer Info so you would need to redo the Painting of textures. It’s partially broken, but if in need of recovering hard work, that is the method i used, you will need to stream the level by opening the levels tab in view menu, and add existing level to the persistent, but it will load based off of BP or always loaded,. Should use BP loaded, until finalized, once lighting is built indenantly on both levels, you can set the sublevel to ALways Lopaded, and it will cook that way as a single level, despite a simple tweek to the streaming method

Triple check the correct drivers are installed.
You’ll be hard pressed to find other people on here with a 3090 or even a 3080 given the dire shortage…

Delete all the reflection captures from the level (move them to a different level so the position is preserved. Then simply unload the level you moved them to to build).

its not your card, check the resolution of your lightmaps. its easy to go overboard and flood the video memory with huge lightmaps…

Resolution isnt the problem… this built fine with my 2080ti… Again this worked fine in previous versions of unreal… on a different computer with a 2080ti at the time. And again… the lightmaps bake… its the reflection captures alone that cause the crash. As in after testing i can literally open the level up… build reflection captures only… and it will crash with that error… Also if i go into project settings and switch the reflection capture resolution to something lower it also crashes… My guess is it tries to recreate them when you switch it.

Latest drivers are installed. I can build the sub levels seperately… but when its all together it wont work… I dont want to have to hide reflection captures every time i do a build.

Looks like you’ll have to until the next driver release and/or an engine fix.

how do they know to fix it if they dont know about it?

Like always, they probably won’t fix it until they have to because fortnite doesn’t load or similar.

The driver update will come anyway. And it could very well be related - usually one update or more a month

Only other thing you can try is to check if you are forcing dx12 or Vulvan in project settings.

Whatever you do, don’t migrate to the preview engines. They are “preview” they could potentially work (and .27 seems to run OK). But they are still “preview” - meaning 9 out of 10 it can break and stall development due to bugs/issues other bs.

You could always put in a bug report.
But as you probably know they have been ignoring all of them / by the time they get back to you the driver will definitely have been updated. If that was at fault your bug report would be pointless.

Although, you could copy the project and test to see if .27 preview gives you the same issue or not.
They messed with light baking too, because they enabled SLI for it 20 years after we needed them to… the updates could potentially have included testing on a 3090 and relevant fixes…

Good point… might see if .27 does anything…

Aside from that in bug reports… i am not sure how to get “Callstack” for them when you mark it as a crash. What is that?

As a test, try deleting all of the reflection captures except for one and see if it builds. If it still crashes, try deleting all of the reflection captures and then add a new one and see if it builds.

To get the call stack you need to install debug symbols.
20gb of wasted space, but if you are actively developing and crashing it’s worth it. It can help debug the engine by pointing you in the right file to analyze…