Download

Out of video memory when trying to open one of my levels (which was fine before)

yea i tried that… now randomly i cant even open up the level anymore … just instant get the crash… sometimes im able to luckily… but eitehr way building lighting with all reflection captures in a hidden sublevel… does crash it as well…

So yea… i can only open the level if i have settings on low graphically… and reflection capture generating crashes it as well… Deleting all the reflection captures nad building it to 100% crashes it as well…

Ive now tested on my rtx 3090 and rtx 2080ti computers both… This wasnt an issue in unreal earlier versions like 4.20…so wtf is wrong with 4.26???

The level built when i removed the reflection captures level… i saved… then readded reflection captures… crashed… Then reopened with reflection captures fine… but hten did build reflection captures and crash…

For anyone still paying attention to this thread… It seems like by creating a brand new project in 4.26 as a game project… and then migrating the entire content folder into that new project from the old one… Seems to have worked!

I can now build lighting and reflection captures no problem. No more crashes.

So than it would stand to reason that you have some engine settings that are causing the crash?

Before migrating, had anyone suggested deleting stuff in your /saved folder yet?
If not, you could check what can be safely deleted and try to re-open, re-build shaders on the old project.

It’s probably the same result as what you did by migrating btw.

Personally would still be interested in knowing why the engine was crashing out over this.

You should give .27 preview a try with a copy of the project too.

Tried all that. No I never set any weird settings… honestly ive been working with this project since like 4.12 … just kept updating to newer versions of engine and i stopped working on it between like 4.22 and 4.26…

Only reason i tried migrating was i read somehwere another person was having a similiar issue. Not quite the same, but same type of crashing. And it could be something to do with somewhere along the line epic starting with this whole game project versus other types of projects… i dont know… Im only guessing. But as i said… project always built just fine before these new versions of the engine. So migrating it like magic from one project to a brand new game project created in 4.26… seems to have fixed it all.

Well for anyone still watching this… I just installed a 2nd 3090 and decided to test doing another lighting build… Back to the same error…

It reaches 100% on the lighting then it reaches 100% on building reflection captures and stays stuck displaying 100% on building reflection captures… After some time i get

“Out of video memory trying to allocate a rendering resource. Make sure your video card has the minimum required memory, try lowering the resolution and/or closing otehr applications that are running. Exiting…”

Followed by it exiting the editor…

Is there any dev that can help me with this? Give me a clue on where to look?

Basically if i build just reflection captures without hte lighting it also gives the error… Its the generating of every reflection capture in the scene at the same time that is causing this crash, but i dont know what to do about it…

You need to get on with epic support.
Which as i think I mentioned will take about 3 months for them to get back to you and subsequently be worthless.

You can try tagging some of the engine devs to this forum post - maybe one of them can escalate and get someone competent enough to address the issue.

Seems ridiculous.

Btw. What version of the drivers are you on? Studio or Game Ready?

probably game ready… how do u even tag people to a forum post… and how do u even find the devs?

@ and the name.
Like @kurylo3d
Then a drop down shows up that you can select the user from.

As far as finding the devs… there should be a forum user directory - but then again that’s assuming a lot given the state of the forum.

Send a PM to our community manager (@VictorLerp) to figure out who needs to see this.

And do submit a bug report too since they’ll ask.

To anyone still watching this… 4.27 still has this error unfortunately even thoug hit supports SLI… dual rtx 3090s… nv link.

1 Like

Any official response of any kind?

Also, there’s been 2 driver updates for the cards since. Do either make any difference?

nope… i once saw a youtube video that said try lowering your resolution since it takes more memory to do things with high resolution like 4k…

Unrelated.
Light building has nothing to do with resolution of the editor or of the monitors.

the crashing part happens on the building of reflection captures part… and that absolutely does. resolution eats up video memory. Try uping any modern day game resolution from 2k to 4k… and ull see it eats up way more video memory. Doesnt explain why i can fly around the scene with no problem… but seems like epics system for building all the reflection captures is just bad right now…

For example sometimes i can actually get the reflection captures to build correctly by looking up at the sky of the level and switching to unlit mode in the viewer… cant tell u why it helps… but it did.