Odd Shadow Bleeding


We are experiencing some odd shadow bleeding on some of our static meshes and are unsure as to why. The lights in these images are spot lights but we’ve also experienced the issue with point lights too. Could this be an issue with our static meshes/UVs ?



I have not seen artifacts like that before. It is most likely due to bad lightmap UVs. Check an existing cube mesh to see what they should look like. They need to be unique (not overlapping) and not wrapping (0-1) and with some space between charts. Also make sure your lightmap resolution is high enough. You can visualize the lightmap texels with the lightmap density viewmode.

I don’t think they are overlapping but I know theres no space between them so I’ll separate them with some space and see how it turns out.



Hi Daniel,

So I’ve Moved the UV’s to a better position, ensuring they don’t overlap and there’s space between charts. I’ve also increased the lightmap resolution of the meshes to 64 and I’m still getting these odd shadow bleeding areas. Infact since I altered the UVs for better positioning they have gotten worse.

Here’s some images:
Although the UV’s look close, they are not overlapping.

The lightmap density looks good on all meshes and those grey areas/cubes should be completely white.

Any ideas?


Dear Zejudge,

Have you tried using the Engine Cube to see if it is indeed the UVs ?

If it is the UVs, you can do a neat trick in 3ds max for your chosen cube.

(export cube if need to as FBX, and import to 3ds max)

in 3ds max in modifer stack go to UV Map, and select box, and and depending on size of mesh enter say 16 or 32 for width and height

then export back into 3ds max

For really simple shapes its a loooot easier to let UV Map do the mapping for you :slight_smile:

I’ve had no issues with this 3ds max UV map process and the kind of things you are noticing in my own project.


Hey Rama,

I’m not sure what the process would be for Maya (it’s what I use) but if you mean automatic mapping? I’ve tried that also. Those were the first set of results.

I’d also like to add that these cubes are imported into engine as large, combined meshes rather than single cubes. If that makes a difference. Either way the UV’s are the same for all the combined cubes.

“I’d also like to add that these cubes are imported into engine as large, combined meshes rather than single cubes.”

oooooh hmmmm

Will get to back to you on this :slight_smile:


Well if you upload one of your cube-combination meshes to drop box, I can do my own uv map test on it and send it back to you, via drop box.

at least then we can narrow down if uvs are the issue


PS: to clarify, send me the FBX please, exported from Rocket :slight_smile:

If you combine the meshes while importing(or attaching them in Maya to each other after UV mapping single cubes) then that sure causes the lightmap issues because every cube’s UVs overlaps each other.

Thanks Rama! :smiley:



Dear Jon,

I uploaded the FBX and the .uasset to your Epic Drop Box folder


One thing to note

The native size of your static mesh is HUGE!!!

Might wanna shrink it pre-putting it into rocket, unless all your worlds are that big!!!

Do you shrink it a lot on import?!

I Had No Issues

I had no issues with using my uv map 3ds max method

please try out the .uasset I gave you and see if it goes well with your lighting build


I dunno of the size of your mesh is having an influence on the stuff you’re noticing but it’s worth trying a smaller native size (native to your 3d modellnig program)

hahaha. I don’t know why the meshes are so big for you as they are only 2000x2000x200 in engine on my end. They look super big on that image. - It might be something to do with opening the file in Max.

Also, opening your returned file has given me these UV’s:

And the uasset doesn’t appear in my content browser :confused:


you added the .uasset into your content directory?

I wouldn’t worry about how the UVs look. I’ve been using the 3ds max method for ue3 and ue4 without ever having any issues :slight_smile:

just try importing the .FBX yourself and doing your lighting build and let me know how it goes :slight_smile:


Hey Rama,

So I imported your returned FBX and this is what happened:

It has the same texture applied to it as the original meshes behind it.


well I was not expecting the texture to be aligned properly given that I just guessed a value for the uv mapping

the real only question is whether there are any strange shadowing artifacts.

pretty hard to tell from this pic.

As you can tell from my pic, the uv mapping worked great for the good ole’ classic world grid material

which makes me now wonder

have you tried using other materials with your mesh to see if this issue is somehow material related rather than Mesh UV related?


PS: I am presuming that if you just imported the FBX as I sent it to you, that the world grid looks same as it did in my picture?

I’m getting the same results no matter what material I apply to it, I’ve tried a basic white, the world grid material and they all turn out with the same issue so we know it’s definitely not material related.

I decreased the scale as the FBX you sent was set to 10. Setting it to 1 made it scale back down to my other object’s sizes.


well now we come to a fundamental connundurruum.

I dont get anything like what you are showing in that picture when I made the asset myself from your supplied FBX!

#Time To Migrate

you can migrate out your exact material and actual static mesh asset in its current form to a folder and zip it and I can try building lighting with it in my rocket install

if you could, before migrating out of rocket, please make a uniquely named subfolder and copy the assets there, and then migrate, that way I will receive it with a folder structure for easier-finding-stuffness

Both the original and Rama’s FBX have overlapping UV’s. The original has only one cube UVmapped properly and the rest are overlapping that one, and Rama’s looks like a planar UV map which is not good for a cube and is bound to give shadowing errors while light baking.

I am making those suggestions based on the given FBX files btw, so my apologies if i’m missing something. :slight_smile:

Ok giving every cube a completely unique UV seems to be solving the issue, just gonna take a while to sort them out.

Thanks for your help everyone! Much appreciated! :smiley:


Hey Mehmet,

So I’ve tried taking just a small amount of cubes, doing an automatic map in Maya, ensuring they don’t have overlapping UVs and have space between charts but it seems I’m still getting the odd shadowing issue. See below:

I’m really not sure what else to do.

Here’s the file:

Really at a loss here.