Object turns black after rebuild of light

Hello, I’m planning in using UE4 for a voxel game, so I’m trying to import some simple meshes I created to the editor.

These meshes are first created using a voxel editor, then, I use a program I created to optimize the number of vertex of the voxel and I create a obj with it, then I use MeshMixer to create an .dae file from my obj (since my obj have vertex color information, which is not supported by default by .obj, I use the MeshMixer which can read this special obj file and create an .dae file with the vertex color information).

With the .dae file I finish importing it to blender or FBX Converter to convert it to .fbx to load in UE4.

Since this is a voxel mesh, there is no need for texture information as all the color information I need is stored in vertex color, so there is no UV Map of any sort.

The problem I’m having is after importing in UE4, the model works great, but if I try to rebuild the light, my object will became entirely black. Bellow there is 2 images, one of the model before the light rebuild, and the other after;

Searching for a solution I saw some people creating a second UV Map so UE4 could use it to lightmap, the problema is that I dont have any UV Map channel at all, I tried inserting the channels with blender and UE4 Mesh Editor but the results are always messed up, it never turns like the first image.

I don’t know if it will help, but I uploaded the model (the .adb and .fbx file) so if anybody can test it in UE4:
[link text][2]

Just for completion, When I import the model, I use an custom material which is simply an vertexcolor material.

So, there is some way to fix it without creating an UV Map? If not, how can I create this UV Map without messing out the light in it after rebuild?


Hi Sezaru,

If you’re using anything that is going to be static and not dynamic/movable you will need to have a second UV channel for your lightmap. The reason being that since you’ve managed to not have any UVs for your object and there is no lightmap UV when the lights bake UE4 will default use the UV channel 1 for lightmapping. Since there is no UV islands present it cannot bake lighting thus giving you the black texture you’re seeing.

I’ve taken a moment and compiled 4 different views of your object:

1 - This is your original object
2 - This is your original object with mobility changed to Movable
3 - In the Mesh Editor I auto-generated a UV layout and changed the lightmap coordinate index to 1 to use it. (Not recommended for complex objects like this. Will not give you the best results with layout)
4 - Used your FBX in 3Ds Max and made a second channel lightmap.

Using either option 3 or 4 will not affect the UV channel 1 (afaik, it didn’t when in Max).

Give this a shot and if you have any further questions feel free to ask! :slight_smile:


Hello Tim,

First of all, thanks a lot for the helpful reply!

Now, if it is not asking too much, can you send to me the fbx you created with 3ds max so I can see how you did the lightmap?

Actually, after I posted this question, I started trying to create the lightmap with Maya and Blender, but it’s the first time I use these applications, so I’m still failing hard to create something good, did it take too much time for you to create the lightmap in 3Ds? I think I will try creating the lightmap with it to see if it’s easier :stuck_out_tongue:

Thanks again!

I’m no longer at work for the weekend to send that to you but I really didn’t do anything special. Since I was working in Max there may be some differences but I know this can be done in Maya and Blender as well. All I did was add a UV Unwrap modifier > Move to the second UV channel > Used Flat Mapping to flatten and throw all the polygons down in the 0,1 space.

Figher5347 (one of our awesome moderators) has a good video to get you started with the lightmap using Blender. He has the equivalent of a flat mapping technique in there. Looking at the scale of your object when I imported it into UE4 (super small compared to the scaled up version you had in the images above, right?) having a very detailed well layed out lightmap may not be a concern.

Here’s the tutorial.

If you have any questions or have trouble feel free to ask! :slight_smile:


When you get the lightmap and import make sure to go into the mesh editor and change the lightmap resolution from 32 to something like 64 or 128. That will get rid of the few artifacts in shadows you’ll get. If they’re still there try 256.

This is ENORMOUSLY helpful. Thank you! Thank you! Thank you!