Download

NVIDIA GameWorks Integration

Thank you very much. As I said, i will try this method the next time I need something merged.

it seems that nvidia gameworks is irritating my computer when i try to use it either in unreal, or when i try to lpay a game that used gameworks. i tried playing “hunter call of the wild”. and my PC had a epileptic seizure.

does gameworks work with AMD radeon graphic cards? or is my PC getting old? after all i had it since 2012. i got like, 8gb ram, 3.4ghz chip, and some radeon integrated graphics card. i’ve been keeping up with most games on the market for the last 5 years without any problems. i cant play on ultra settings. but on low-medium or high it usually works fine. with thhis new gameoworks frmo nvidia though… my PC starts sweatin.

it seems that nvidia gameworks is irritating my computer when i try to use it either in unreal, or when i try to lpay a game that used gameworks. i tried playing “hunter call of the wild”. and my PC had a epileptic seizure.

does gameworks work with AMD radeon graphic cards? or is my PC getting old? after all i had it since 2012. i got like, 8gb ram, 3.4ghz chip, and some radeon integrated graphics card. i’ve been keeping up with most games on the market for the last 5 years without any problems. i cant play on ultra settings. but on low-medium or high it usually works fine. with thhis new gameoworks frmo nvidia though… my PC starts sweatin even when i turn everything off, and on low settings. its un-playable. all that gameworks foliage is blinking like a lamp turning on and off.

Think I will finish UE4.15 Gameworks integration with all or Turbulence off, and with AMD LiquidVR, and some fixes and improves. This weekend.
I will post and share compiled one, because I don’t have Graphics for VR, but one OSVR hacker dev kit in standby till I can afford new PC for VR.
I will make it version compatible with Epics Binary release as well, to support UE market plugins and assets.

Added:

Gameworks:

CataclysmDemo Yes
FleX Yes
Flow Yes
HairWorks Yes
HBAO+ updated to the last version Yes
Turbulence Yes or No ?
Volumetric Lighting Yes
VRWorks Yes
VXGI Yes
WaveWorks Yes

AMD LiquidVR and updated Yes

With Simplygon ready Yes

LIBS:
NVIDIA AnselSDK updated Yes
Steamworks 139 updated Yes
NVIDIA API R378 updated Yes
AMD AGS_SDK updated Yes
Intel TBB 2017 version updated Yes
PhysX-3.4 updated Yes or No ? (dependency for Turbulence)
Vulkan updated Yes
FBX 2017.1 Yes
Windows 10 SDK 10.0.14393.0 working in this, i have failed before but already know why! Importing some knows from Microsoft.
.
.
Cleaning VXGI macro predefs, that in packaged builds has conflits.
So always with VXGI in compile time.
And NO: Win32, HTML5, Mac, Android, IOS, TVOS, Linux, PS4, XboxOne, Switch, builds.
Only for Win64 builds. This for all the UE4.15 compile time and builds.

I cant afford killing my time trying to debug like crazy UHT for others platforms.

shout some names for ‘Community Edition’ for in editor an release build, like ‘GPU Fanatic’s Community Edition’ or ? shout here…

@VItorEAFeliciano holy **** that sounds too good to be true, if it indeed is true, you are a saint.

holy moly? xD, I need to give to the community what I have learning last years with, and learning with feedback situations give me some ideas what to search for.
This its a start point to make a better source implementation.

Wow.thank you for your hard works.i cant wait for using your branch

Hey dude ! that would be so cool !!! Thanks a lot ! Sharing your version would be an awsome help and would definitly make my day (any day it shows up of course ! No hurry ! :wink:

I’m a newbie with all that github stuffs so i would apreciate a lot a compiled version of all that advanced techs.

I’ve tested VXGI and Hairworks and it looks very promising but I’d like to use both in UE4 and an “expert” compiled version will be much more easiest to use…

Also, Did anyone know if we can use VXAO in ue4 ? Is there a link to a branch using it ?

And last but not least: Is the “VR left eye only shadows” in VXGI fixed ? It really kills the experience (with HTC vive for me…).

Thanks again a lot VItorEAFeliciano, can’t wait for your release !
Have a nice day !

@gonzohot VXAO is a part of VXGI branch, you can make VXAO run without GI by typing r.VXGI.AmbientOcclusionMode 1

You can read more about it here: VXAO: Voxel Ambient Occlusion | NVIDIA Developer (about Unreal Engine section is at the end of the page).

Thanks overfuze !
That’s true: I now remember that i quickly tested it some times ago but it turns all my scene Black, and I just didn’t figured out why…

EDIT: i just tested it again and it seems to work but i don’t really see any differences with just HBAO+ enabled

Yeah I don’t really see the difference that much myself either, but you can set the visualization mode to Ambient Occlusion and switch r.VXGI.AmbientOcclusionMode between 0 and 1 and you will see the change.

EDIT: Here is an example Screen capture - b4dac81d1e9c59a1cefc8ccad12815ab - Gyazo (command I entered was r.VXGI.AmbientOcclusionMode 1)

@Andrew.Reidmeyer So I made a test animation and pushed Flow’s couple rate and substepping both to 10, and while the emittance does continue while it’s moving quickly there’s a very visible stepping between frames. The only solution I was able to find to make it smooth out is to push the grid’s simulation rate to 120, which to me sounds like a terrible idea in terms of performance. However, it did result in a 100% completely smooth animation and looks perfect, just what I’m looking for. Are there any other settings that may be able to get that kind of result without taking what sounds like a pretty bruteforce approach? I’m using it on a weapon in an arena fps of sorts, and need to make sure this sort of thing doesn’t cause any slowdown.

Also, I’ve been looking at the Flow VR settings to get ideas on how I could potentially optimize things, but as there isn’t any documentation on Flow that covers performance directly (although I have found the gameworks documentation page for it, which helped a lot), what settings would you say to look at first to make it run as fast as possible?

There is some latency to make new blocks active. For fast moving emitters, there are two settings. One is ‘allocation scale’, this can be increased to values greater than 1.0 to allocate a larger active region around the emitter. Very useful for hand held emitters in VR, where it is less trivial to predict the future emitter location. Another is ‘allocation predict’, this attempts to allocate based on emitter velocity, so is a directional form of prediction.

To visualize the effects of both parameters, use the ‘flowvis’ command, and look at the wireframe around the emitter.

Lower simulation rates will tend to offer better performance, although 90 Hz is the typical value used with VR, to align with vsync. Performance in general will scale based on the number of active blocks, so flowvis serves as a tool to notice active blocks that might not be contributing enough to justify the allocation.

I’ll try it out when GitHub isn’t completely retarded and they release it somewhere else, or with the engine (like it should be). It’s the worse popular service on the entire internet.

You right,

Tessellation can’t be done with VXGI Voxel’s in the same material,



// NVCHANGE_BEGIN: Add VXGI
	if (RHIIsVoxelizing() && !MaterialRenderProxy->GetVxgiMaterialProperties().bVxgiAllowTesselationDuringVoxelization)
		{
			return false; // not allowed
		}
// NVCHANGE_END: Add VXGI


I did some more testing locally with fast moving emitters, analyzing the substepping interpolation frame by frame.

In the case of unlimited FPS (~200 FPS range in this case), I did see substepping interpolation that could be made smoother. We will work on improved interpolation for this case.

You can verify if this is the issue by setting t.MaxFPS to align with the simulation rate.

This issue did not manifest in previous VR work, where simulation rate was aligned to FPS.

This is exactly what I’ve been seeing on my end in a test scene:

I did the test with setting t.MaxFPS to 60 and can confirm that limiting the FPS did actually fix the sim rate at 60 and made it look as smooth as the 120 fps one. At 120 fps, it almost seemed like substepping wasn’t having any effect on the 60 fps sim, where it’s clearly working perfectly once it was capped.

can someone help me getting a flow emitter to work?

the sample project works fine, but i cant get a new emitter to work.

i add a grid asset, i create a blueprint actor with a sphere and add an emitter component. whats next?

can’t wait for this custom build XD

I vow to stop eating until this is released. We’re talking about a man’s life here guys!