NVIDIA GameWorks Integration

Thought I’d share my character using HairWorks.

HighresScreenshot00023 copy.JPG

Did you ever find a solution to this? Not sure if it’s the exact same error for me, but enabling particle mode crashes the editor for me as well. Unsure how to go about testing Flex at the moment. Also noticed that some of my editor options are missing compared to GalaxyMan’s screenshot of the component.

Has anyone had any luck integrating the community OceanProject? Tried the 4.9 branch and then just a simple project folder re-compile but it failed. Seems to think it is the wrong version…

Excellent stuff though GalaxyMan! Thanks for the work you’re putting into this.

it is possible to have a guide on how to integrate hairworks in other UE4 versions?, for example what files or assets do we need to include in our UE source .Net project?.
I am already working with UE 4.8 and I dont want to migrate all my code and assets to Nvidia’s UE versions. :).
By the way, thanks a lot for making hairworks working with UE. I have been waiting for this long time :smiley:

The new integration is still based on UE4.7.5. The next coming release should be based on 4.10. If you don’t want to do the upgrading by yourself, I think you have to wait for that. :slight_smile:

Hi GalaxyMan,

Was wondering about similar issues too…is it actually possible to get Flex particle position/velocity, as well as collision position/normal/speed? (basically all the metrics exposed by the Flex API itself)

Cheers :slight_smile:

hi guys.
i am using Galexyman2015 branch v4.9 . Thank you for you hard works. :slight_smile:
I have tow questions about flex:

  1. Is there any tutorial on how to using flex? pdf or sample or video?
  2. I am using apex and maya for creating cloth but unfortunately i got that exported cloth not interacted with world i want to know that flex cloth is same as apex cloth or it can interact or collide with world?

Sajjad shirzadi.



1)Not sure if it is in galaxymans branch, but in official flex branch in UnrealEngine/FlexProject/Documentation/ is a documentation.

Newbie question, why do bouyant objects not change rotation on the WaveWorks ocean? All objects can move around, but they don’t seem to rotate at all on the water. In this demo the ship rotates, am I doing something wrong?


EDIT: Another question, how can I set Waveworks to only interact with certain static meshes instead of everything? When I set any static meshes to Static, the game runs slower and slower until eventually it crashes, and when I set the static meshes to Movable, then they float along with the waves no matter what I try.

Is there any way to get rid of the visual representation of an emissive object in VXGI without loosing them as lights?

I am using some emissive planes to light my scene, but I don’t want to see them.
Something like “primary visibility off” in Maya. So they still emit light, but cannot be seen in the users camera?

Hello everyone! I’d like to mention that we just updated HairWorks on GitHub. This is still for UE4 4.7.5 and is compatible with an updated set of HairWorks 1.1.1 tools on Devzone. This release has plenty of bug fixes, functional improvements, and has an improved workflow. We do not have a 4.10 version ready just yet. I’ll post it here as soon as it is.

Hello everyone. I’d like to mention that we updated HairWorks on GitHubfor UE4 4.7.5. The associated tools for HairWorks 1.1.1 can be found here. This new update fixes a handful of bugs, introduces new functionality, and improves workflow. We do not have a date for HairWorks in UE4 4.10, but we are working on it. Enjoy!

I guess by the time you have it Epic will release 4.11 so maybe you want to be a head of the game and work on 4.11 instead :wink:
(Just a thought)

Anyone have problem with mesh that have opacity shader in it?. When a select the mesh, they act like they are supposed to, but when they are unselected, the light doesn’t got through? Do i need to download VXGI translucidity and if yes…how i’m i supposed to install it :stuck_out_tongue:

Hi guys, not sure if this is the right place to ask, but I am wondering if anyone has encountered a problem with HairWorks and Maya.

Basically the issue is the Hairworks node in Maya doesn’t let me change the “Resample Guides” number and is constantly stuck on 4. I can type any number, but when I select anything else in the scene it resets back to the default.

I am using Maya 2016, Hairworks 1.1.1 and the 4.7.5 branch of Unreal.


It exports guides with 4 segments no matter what I do.

This results results in bald spots when imported in the engine.

Anyone got any tips?

Figured it out, looks like it’s bug in the newest build of HairWorks for maya “Maya_2016_64bit_1.1.11028.12482”
I tried it in maya 2015 aswell with the newest build. Same issue.

So I downloaded an older build “Maya_2016_64bit_1.1.10506.22462” and the bug was gone.

I would report it to nVidia but don’t know how!


I was reported to NVIDIA(
Nvidia is said to fix the bug.

I don’t think its a bug… that is the max resamples supported at the moment. the Hair component settings in UE4 too allows a maximum of 4 at this time.

As for the Bald spot, play with your root stiffness and also helps to have proper density maps applied to the scalp

I don’t want to seem impatient, but I was wondering if you could tell us how far along with 4.10 you are?

The bug I experienced didn’t allow me to lower the number either, it was stuck on default. I had no issue bumping them up to 16 once I had downgraded the plugin to an older version.
The setting you are thinking of in Unreal is the Spline Multiplier, which indeed is maxed out at 4.
This is what I got in the end.