Download

NVIDIA GameWorks Integration

Build in Development Configuration as well. Then try repackage.

I am using Windows 10 Pro x64. Could this be the problem? I will make today another try with the Development Configuration. It would be fantatastic if this helps. :slight_smile:

Okay donated you right now :slight_smile: again your are the master when it comes for merging branches :slight_smile:

I started a new test with Development Configuration. (32+64 Bit) The error is the same. :frowning:

That should work, thats my normal setup, Development Editor Build, followed by Development build (So game packaging will work for BP only games). Then launch and package. Should not give out any errors relating to UE4Game.exe. Look in your directories, do you have a UE4Game.exe, if not, then you haven’t compiled a Development build.

@GalaxyMan: I wanted to be sure that my projects are not faulty. For this reason I created a completely new project with version 4.91 (+Starter Content). I enabled VXGI and HBAO+. Nothing more. Then I started the package process. I get the same error as the last times. (UE4 game binary is missing) Unfortunately this seems to be a bug in the current build. :frowning: Perhaps an incompatibility with Windows 10?

As I said, it shouldn’t be, I am running Windows 10 x64. And I am also using 4.9.1 with my merged branch and I have no issues packaging. It may be an issue with NVIDIA’s branch, but I do not see why mine would not be affected by the same thing. Looking through my commit history, there is one possible commit that may be why its working for me, but that would actually result in a compile error during the Development configuration.

Can you please check if you have a UE4Game.exe in the Binaries/Win64 directory. If you do not, then maybe it did actually fail to compile the Development configuration. If so, I can suggest a fix.

I have checked this. You are right. There is no UE4Game.exe in my Binaries/Win64…But why?! I compiled the build two times. (wthout any old data) And I get no compiling errors. ??? I don´t understand this.

maxwell try this :
Build the “Development Editor Win64”
Build the “DebugGame Win64”
Rename the “UE4Game-Win64-DebugGame.target.xml” in Engine/Build/Receipts to “UE4Game-Win64-Development.target.xml”

@iuhiuh Thank you very much for this information! :slight_smile: I will try this. I thought that I have understood the whole build process. But I was wrong. :frowning:

NP maxwell :slight_smile: galaxyman is there a way to save the command r.hbao.enable 1? because if i restart my editor its always r.hbao.enable 0

Unfortunately, I have still a question of understanding: Can I find the “Development Editor Win64” and the other files in the Visual Studio Solution Explorer? (in GalaxyMan´s build)

here :http://www2.pic-upload.de/img/28582999/Unbenannt.jpg
building project worked for me

@iuhiuh Sorry, at the moment I am unsure what to do. As I understood I select “Development Editor Win64” from the dropdown menu. After that I click on UE4 in the Solution Explorer and select “Build Solution”, right? All the same I should do with “DebugGame Win64”…The last thing which has to be done is then the file renaming…

yep exactly what you said :slight_smile: choose developement editor win64 and then build ue4 and then next step the same with debugGame win64 or if that debuggame fails, try to use DebugGame editor
and than last step : Rename the “UE4Game-Win64-DebugGame.target.xml” in Engine/Build/Receipts to “UE4Game-Win64-Development.target.xml”

@iuhiuh Thank you very much! :slight_smile:

@iuhiuh One last question… :wink: When I start from scratch the first thing I have to do is to compile the Engine as described in the tutorials which were published here, right? After that I build the “Development Editor win64” and the “debug editor win64”?
At the moment I get compiling errors in Visual Studio. For this reason it is the best to start from scratch again.

is there a way to make hairworks work with morph targets?
so that for example a beard moves correct when the mouth is opend by morph targets.
it seems to work just for bones =(

I am frustrated at the moment. I did everything to create the UEGame.exe for packaging my projects. But I get always compile errors in Visual Studio. I dont know where the mistake is. First, I selected “Development Editor Win64” in the dropdown menu in Visual Studio. I selected the UE4 icon in the Solution Explorer, right click “build”. When everything is finished I selected “debugGame win64” in the pulldown menu. Then right click on the UE4 symbol (Solution Explorer) and start building. So far, so good. But then this happens:

error.JPG

What is going on there? What am I doing wrong?!

Unreal Engine 4.9 VXGI commands (press ~ ):

r.VXGI.AmbientOcclusionScale
Scale factor for the voxel AO result.
1.0 = default

r.VXGI.CombineSpecularWithSSR
Defines if VXGI specular tracing fills is combined with SSR or replaces it
0 = replace (default);
1 = combine;

r.VXGI.CompositingMode
0 = add the VXGI diffuse result over the UE lighting using additive blending (default);
1 = visualize the VXGI indirect lighting only, with no albedo and no AO;
2 = visualize the direct lighting only;

r.VXGI.DebugBlendOutput
Alpha blend debug output
0 = disable (default);
1 = enable;

r.VXGI.DebugClipmapLevel
Current clipmap level visualized (for opacity and emittance debug modes)
15 = visualize all levels at once (default);

r.VXGI.DebugVoxelsToSkip
Number of initial voxels to skip in the ray casting if r.VXGI.DebugMode !=0 ;
0 = default;

r.VXGI.DiffuseMaterialsEnable
Whether to include diffuse lighting in the VXGI voxelized emittance
0 = disable;
1 = enable (default);

r.VXGI.DiffuseTracingEnable
Whether to enable VXGI indirect lighting
0 = disable;
1 = enable (default);

r.VXGI.EmissiveMaterialsEnable
Whethet to include emissive materials in the VXGI voxelized emittance.
0 = disable;
1 = enable (default);

r.VXGI.Emittance6D
Whether to use 6 emittance projections per voxel
0 = 3 projections;
1 = 6 projections (default);

r.VXGI.EmittanceInterpolationEnable
Whether to interpolate between downsampled and directly voxelized emittance in coarse levels of detail. Sometimes

this interpolation makes illumination smoother when the camera moves
0 = disable (default);
1 = enable;

r.VXGI.EmittanceShadingMode
0 = use diffuse color = base color - base color + metallic (default);
1 = use diffuse color = base color;

r.VXGI.EmittanceShadowCascade
Restrict the emittance shadowing to a single cascade
<0 use all cascades, otherwise the index of the cascade to use;
1 = default;

r.VXGI.EmittanceShadowEnable
Whether to enable the emittance shadow term
0 = disable;
1 = enable (default);

r.VXGI.EmittanceShadowQuality
0 = no flickering;
1 = 2x2 samples (default);

r.VXGI.EmittanceStorageScale
Multiplier for the values stored in VXGI emittance textures (any value greater than zero).
1 = default

r.VXGI.ForceDisableTonemapper
Disable tonemapping
0 = false (enables tonemapping, default);

r.VXGI.ForceFrontCounterClockwise
0 = default;

r.VXGI.ForceTwoSided
0 = default;

r.VXGI.GSPassThroughEnable
Enables the use of Maxwell geometry shader pass - through feature for voxelization, only effective when value

r.VXGI.NvidiaExtensionsEnable=1
0 = disable;
1 = enable (default);

r.VXGI.HighQualityEmittanceDownsamplingEnable
Whether to use a larger triangular filter for emittance downsampling
0 = disable (default);
1 = enable;

r.VXGI.MapSize
Size of every VXGI clipmap level in voxels. Valid values are 16,32,64,128,256.
128 = default;

r.VXGI.MultiBounceEnable
Whether to enable multi-bounce diffuse VXGI
0 = disable (default);
1 = enable;

r.VXGI.MultiBounceNormalizationEnable
Whether to try preventing the indirect irradiance from blowing up exponentially due to high feedback.
0 = disable;
1 = enable (default);

r.VXGI.NvidiaExtensionsEnable
Controls of use of NVIDIA specific D3D extensions by VXGI
0 = disable;
1 = enable (default);

r.VXGI.Opacity6D
Whether to use 6 opacity projections per voxel
0 = 3 projections;
1 - 6 projections (default);

r.VXGI.Range
Size of finest clipmap level in world units
60 = default;

r.VXGI.RoughnessOverride
Override the GBuffer roughness
0 = default;

r.VXGI.SpecularTracingEnable
Whether to enable VXGI reflections
0 = disable;
1 = enable (default);

r.VXGI.StackLevels
Number of clip stack levels in VXGI clipmap (values 1-5)
5 = default;

r.VXGI.StoreEmittanceInHDRFormat
Format of VXGI emittance voxel textures
0 = UNORM8;
1 = FP16 (Maxwell) or FP32 (other supported GPU’s);

r.VXGI.TemporalReprojectionEnable
0 = disable;
1 = enable (default);

r.VXGI.ViewOffsetScale
Scale factor for the distance between the camera and VXGI clipmap anchor point
1.0 = default

r.VXGI.AmbientOcclusionMode
Set voxel AO mode
??? = default;

I would like to download all integrated NVIDIA Gameworks functions in one package. Recently I tried VXGI branch and it works fine, but for Turbulence, Waveworks, Hairworks etc. I have to download every branch separately :frowning: … I hope that someone will upload full UE4 with all Gameworks options or maybe another solution exists.
Also I have question for NVIDIA : when will be release NVIDIA FLEX for Fermi-based video cards ? I have good old GTX570 and I have CUDA 2.0, so FLEX doesn’t work for me, but I heard about coming FLEX for all DirectX 11 graphics cards.