Not setting Android Package Name correctly in settings causes project launch failure

I’ve been launching my project fine for weeks now. After making a few changes to the project settings to try to get play integration to work, launch is now failing. I can’t fix it though, even by undoing all the changes I made.
I have no idea what the actual cause of the launch failure is, and I’m hoping someone else might know based on the log.
-Edit- Full log posted below

I can launch it fine on Windows. Launch only fails when trying to send it to Android.


In order to better assist you, could you please try to package a blank template without any starter content in it to your Android device? If that fails, could you please upload those output to your next reply?

I’d also like your full from what you originally posted to be attached to your next reply as well, along with the type of Android device you’re deploying the build to.

Looking forward to hearing back from you, thanks!

Deploying a blank project works, as does the Tappy Chicken project.
Only my own project is failing, and only when sending it to Android.
I’m running it on a Samsung galaxy note 3
[Here’s the full log.][1]

50231-log.txt (539 KB)


After reviewing the provided, it looks like your project is having issues with this specific error: ERROR: cmd.exe failed with args /c “C:\apache-ant-1.8.2/bin/ant.bat” debug

[Here is a thread][1] of information that you can go through in order to resolve this specific error. Unfortunately, it’s one of those errors that could have multiple reasons as to why it’s not working, some not even related to the editor therefore, please follow this [link][2] and review the steps necessary.

If you have any further questions or concerns, please let us know.

ERROR: Exception in UnrealBuildTool: ERROR: cmd.exe failed with args - Programming & Scripting - Epic Developer Community Forums
[2]: ERROR: Exception in UnrealBuildTool: ERROR: cmd.exe failed with args - Programming & Scripting - Epic Developer Community Forums

Those links both go to the same thread. Also, it assumes that the problem is with TADP itself, which I don’t think is the case, since I’m only having the problem with a specific project.

Yes, I placed both of the links to go to the same thread. I did not mean to cause any confusion.

The specific error that you’re receiving could be one of a hundred different types of issues, which is why we suggest that you start with the suggestions listed on the AnswerHub post. Did you try them already?

Now, if you obtained the Editor through source, please make sure that you did compile correctly for Android through Visual Studio. As I did notice a compiling issue, that could have been part of what’s wrong too.



I am not sure whether or not you’re still having this issue as I haven’t heard from you within the last 24 hours. However, I would highly suggest that you go into your project folder and delete the ‘Intermediate>Android’ folder. Once you’ve done that, load up your project and go into your ‘Project Settings’ > ‘Android’ and look at: Android Package Name.

If this space is blank, or has any spaces, it could cause problems. Please make sure that com. is still included when you’re naming your project. For example: ‘com.SamanthaCorp.’.

Once you’ve done that, I would ‘save all’, close and reopen your project again and then attempt to launch it onto your Android.

Please let us know if you run into any additional troubles, thank you!

I tried it, but the result is the same.
I’ve also found though that it isn’t launching perfectly well on other devices. When I launch it on Windows, it succeeds, but still [gives errors in the log][1] and fails to use saves inside the game. I had to cut several MB worth of code from the middle of that log, where it basically just kept repeating “Accessed None ‘Save’” after checking some value.

I’ve also found that even on a blank project, I’m getting [errors on initialization][2] of the project itself, and [more again when I launch it][3] despite it succeeding.

50648-windows+log.txt (1 MB)
[2]: 50646-initialize+log.txt (10.7 KB)
[3]: 50647-blank+log.txt (524 KB)

Hey ,

Could you please check over the assets used in your project for mobile devices and make sure that they’re compatible with Android devices? A good way to check this is to use the ‘Mobile Previewer’ within the editor before packaging your game out. Here is some documentation that may be useful to you regarding [Mobile Game Development][1].

Could you please try to launch Tappy Chicken and package it for Android the way you have been packing your original project? If this too fails, please provide the . If it does not fail, we will at least know it’s specific to your project.


General Mobile Development for Unreal Engine | Unreal Engine 5.1 Documentation

Mobile preview works fine.
Tappy Chicken launched fine originally, but changing the android settings to match my project, as you suggested, [caused it to fail.][1]
This involved resetting the package name to the default value, and deleting the values found in distribution signing and Play services, leaving them blank.
This is interesting though, because these are the settings I was using previously, when my project was launching successfully.

50801-chicken+log.txt (600 KB)

I’ve successfully narrowed it down to the project name. Using the default of “com.YourCompany.[PROJECT]” causes the failure. This was definitely not the case before I started trying to integrate Play, and setting my own name does not fix it. Not even copying the name used successfully by Tappy Chicken works on my project.

Hey ,

When you’re packaging for Tappy Chicken you need to make sure that Services is off because we own Tappy Chicken therefore, you would not have the key signatures in order to actually package for distribution. However, if you package for deployment without Play enabled, it should work fine for you.

Could you please provide us some screen captures of your project settings, including your Android settings so that we can look closer and what you’re actually entering in the different fields?

Feel free to provide as many screenshots as possible to cover any other questions that we may come across.


Tappy Chicken is unchanged, so Play services is off. Besides, Tappy Chicken launches fine unless I change the project name to match my own project.

Here’s a screenshot of my own project settings.

Originally the project name was different, but I changed it to be the same as Tappy Chicken just to see if it would work. Obviously it did not.

Hey ,

Would you mind trying to delete the [Project]/Build/Android/src/com directory? There may be multiple copies of the which could cause this process to mess up.

Please report back here once you’ve tried that. If there are any additional to provide do not hesitate in attaching them to your next reply.


I might be noticing fewer errors in the [log][1], I’m not sure. But it is still failing after deleting that.

50829-log.txt (353 KB)

Hi ,

Please try deleting the entire Build/Android/src directory. Based on the blank package name in the log it appears it must have generated the downloader java files with a blank project name at one time so they aren’t even in the com directory; they are just in src. Getting rid of these should fix it; anything in Build/Android gets copied to Intermediate/Android/APK before Ant is run.

That did fix it, it’s running now. Thank you.

FYI, that title change someone put through sounds wildly passive-aggressive.