Download

Noisy / Blotchy Shadows in UE5

Hey guys. Just experimenting with importing a UE4 4.26 project into UE5 and everything is looking fantastic apart from the shadows. I know this a common issue as I have seen a few posts about it (all of which I am following) but I haven’t yet seen any responses to them.

I have highlighted the worst areas in the scene with a red circle and the blue arrow shows that each wall is its own mesh. (See yellow outline).

Resolution on everything in this scene has been set to 2048 to eliminate low quality meshes.

The material applied to each wall and the ceiling is a simple white colour with a flat spec and roughness applied.

I have a PostProcess volume in the scene but whether Enabled or Disabled the shadows are still an issue.

The scene is set up to use Lumen and I have restarted the engine after editing the preferences.

The lighting is using the SkyAtmosphere system and there are no other lights in the scene.

The list of things I have tried is rather extensive, but before I go into listing everything out (and turning this question into a novel!) perhaps someone might be able to point me in the right direction of what I could do to resolve this?

As always, thank you in advance for any help.

Much appreciated,
Jon

i dont know about this but all i have seen is UE 5 is not enough good as in trailer

So you just have a SkyAtmosphere and no directional light or local area or point or spot lights in the scene? it looks like you might have a directional.

try it with a directional, SkyAtmosphere, skylight and volumetric clouds.

make sure the skylight is set to realtime and raytraced shadows enabled. make sure everything is movable in the lighting system and not stationary or static. make sure the directional light is set to be the sun and sky light. also, check the mesh distance fields and see if they are detailed enough.

Hey man! Really appreciate the feedback.

I should have clarified my lighting setup a little clearer, my apologies.

Settings

Sorry, when I said I didn’t have any other lights in the scene, I mean’t like spotlights, point lights or rec lights which could have been clashing with the main directional light.
I have also gone through and checked everything is set to moveable and that raytraced shadows are enabled, which they are and unfortunatley there is no difference in the scene.

I’ve also noticed that I am getting splotchy shadows around the scene. The worst is in one of the upstairs rooms where it looks a real mess.

I can’t put my finger on what would be causing this. :frowning:

Edit: I also thought it maybe the glass in the window having some issue with light refraction, but ive hidden them and its still the same! The plot thickens!

Anyhow, if you have any other ideas, would be greatly appreciated!
Cheers, Jon

Yea, thats the result that i get with older projects as well, cant figure out why.

but what do you mean by:
“Resolution on everything in this scene has been set to 2048 to eliminate low quality meshes.”?

Try turning hardware raytracing off I’ve been fighting shadow artifacts for a few days now and the culprit seems to be the RTX raytracing doesn’t play that nicely yet with Lumen. switching it off and just using lumen seems to solve it… if anyone has any other suggestions the please let me know as well.

hey! Sorry I meant low quality lightmaps, not meshes. My mistake.

I have hardware raytracing turned off already. I have just this minute gone through all the render settings and tried to adjust every single option to see if anything affects the shadows. Nothing. :frowning:

why do you need lightmaps if you are using Lumen?

I thought maybe having the lightmaps set at 128 may have been responsible for the low quality lighting in editor. I just ramped them up to 2048, just to be sure. (But yeah, that wasn;t it!)

Increase the “Final Gather” Setting in your Post Process Volume to get rid of the splotchy GI. 5 works good on my system, moving it to 6 really hits the performance.

You can try adding a plane or box just above the ceiling and/or enable double sided materials.

Also getting the Noisy shadows as well in most my test projects, can’t see to figure out whats causing it either.

This can happen when light has to bounce many times to get to a certain spot or when using emissive surfaces as light. On both cases the amount of rays is limited thus the denoiser can be very visible.

Suggest adding more direct light, bigger windows or secondary light sources to try and hide this.

Firstly thank you to everyone for your feedback. Hugely appreciate it.
So I tried a few more of your ideas in the scene and this is my findings so far…

“Increase the “Final Gather” Setting in your Post Process Volume to get rid of the splotchy GI. 5 works good on my system, moving it to 6 really hits the performance”.

It seemed to make no difference in clearly up the splotchy results with a setting of 5…6…8…12…30…75…or even 100! (pictured)
(The Post Process is definitely enabled as the setting to adjust Final Gather becomes disabled if its not. Ive also tried it on a confined volume and an infinite unbound, and still no difference in the results?).

Next, I went back to the kitchen shot and tried:

“You can try adding a plane or box just above the ceiling and/or enable double sided materials.”

I added a box above the roof plane to see if it would have any effect. Unfortunately not. I then set the walls and ceiling marked with an X to use a double sided material. As you can see, same result.

I then tried:

“Suggest adding more direct light, bigger windows or secondary light sources to try and hide this.”

So I tried absolutely blowing out the lighting to see if I could nuke that noise, but even at 80.0 lux, the noise is still there!
As for option 2, unfortunately the design is fixed and I cant make any structural changes to the build.
I think maybe the secondary light might help, (I haven’t tried that yet). I was really trying to find a way to tweak the setings to get a natural response from Lumen without having to help it or fake lighting to get the right result.

(I guess the next question is, are people still using rec lights to help their interior scenes?)

You mean it’s all one mesh?

No. the walls, roof, floor etc are all seperate meshes.
I mean’t the actual design of the house cannot be changed (e.g. making the windows bigger) as this has all been designed by the architect.

Wish I could be of more help.

All I can think of is linking this and hopefully one of those might help you with how your level was designed: Lumen Technical Details | Unreal Engine Documentation

BTW, what I meant by this not raise the light intensity, was find ways to add more light; more light sources or another angle to get more light through the window.

That final gather slider seems to be broken to some folk, probably related to ported projects. It doesn’t do anything for me either, no visual or performance difference no matter if its 0 or 5000 but it does seem to fix it in projects created in ue5