No soft shadow under objects

Hi everybody,
I’ve modeled an interior and now I’m trying to set the lights correctly: I’ve tried using both a “default” setup, and the “xoio Berlin Flat” setup but all the soft shadows inside are always missing

In this screenshot I’m using just 1 Light Source setted as “xoio” one, a white material for everything; the building light quality is setted on preview but I’m not having a good results even with “High” quality (but xoio berlin flat is set in preview and it has all the soft shadows under the table, ecc)

any ideas?

Make sure lightmass importance volume is covering the whole building and those meshes are static.

Hi Hainzgrimmer,

Leading off with what Jacky suggested you’ll want to also make sure that you’re using Production for the light build. This will provide higher quality light bake shadows. The Xoio Berlin Flats actually used the Production setting for building as well, but when you download and open the project, the settings for things like light build quality are reset to Preview, which will use much lower quality settings than Production.

You will also want to make sure that your Lightmap Density (You can check this in the Lightmap Density View mode) has enough information there to bake quality shadows and produce good bounce results.

There are a number of factors to consider like the ones above, Lightmass Settings for better quality, Static Mesh UV Layout and Mesh construction.

Try some of these and let us know if you’re still having the issue.


Thanks Tim: during these days I’ve studied A LOT about your lightmass and the .ini files on unreal forum and on internet in general and my problem was just the Static Lighting Level Scale and improving that I had way better result even just with preview quality (production quality take really too much times for me now)
Unluckily I have a much bigger problem now: it started (apparently) without a reason but now whenever I try to build the lights I receive the “WorldInfo_0 Maps need lighting rebuilt” and then the building get stuck at 1%: I’ve already read and tried some fix I’ve found here but nothing works and now all my files don’t build lights anymore (evevn if I try with my colleagues PCs)!

It may appear to be stuck, but it’s calculating and building the lightmaps.

You can view the log in and status of the light build if you open Swarm Agent via the task tray with the Yellow/Black “S” icon.

When you lower the Static Lighting Scale, you will see significantly longer light builds and if you’re using higher lightmap resolutions this will increase it exponentially as well.

You don’t need to worry about the “WorldInfo” warning specifically, because when the light build finishes it will no longer appear, if the light build completed successfully.

I’m sorry I’ve caused such a mess: when I opened this question I was working with the 4.10, meanwhile I’ve found that lowering the “static lighting level scale” you get better results; after I tried to convert the file for the 4.11 preview 5 version and found that it was way faster and give better results so I started working with the 4.11 version; after 2 days of working with 0 problems I suddenly started having troubles with the “worldinfo_0” error and I tried working on it till friday late night: I even tried to leave it working but after 30 minutes it was still stucked at 1% (1,76% according to the swarm agent); this morning I decided to try with the 4.10 again, so I took my old 4.10 file and I brought it to be the same of the 4.11 file (lightmass settings, models, materials, textures, everything was the same, just in a 4.10 file) and I built the light: 10 minutes!
Today I worked all the day adding models, materials, pumping the settings a little higher but I reached 20 minutes maximun of building time and no “Worldinfo_0” errors! I’m really really really really sorry for all this mess but I’m feeling that the problem was the 4.11 preview 5! With 4.10 for now everithing is really fine!!!

4.11 has the new Embree RayTracing method for lightmass calculations. Should be ~2 times or more better than the method used in 4.10 and prior versions.

The world Info issue has been reported, but it shouldn’t prevent any light builds from occurring or completing properly.

There are a couple of ways you can track what objects in your scene to see where lighting calculations are taking the longest and/or where they got hung up in the build process. Understandably, you’ve got something that works for you in 4.10, but if you ever need to track this down this info can be handy.

While the light is building for the scene:

  • Open the Swarm Agent application from the TaskTray in Windows (Yellow Black S icon).
  • Go to the Settings tab and set the Verbosity to Super Verbose
  • Go to the Logs tab and you can see the logs for what’s being built/calculated and other things.
  • The status tab will show you the status and progress thus far in the build.

When the build is complete:

After the light build has completed, you can navigate to the Menu bar > Window > Statistics. This will open a new window with all the assets in the scene listed. There is a drop down in the top right that you can use to select Lighting Build Info.

Once this option is selected it will show the time it took for assets to be calculated and built, along with a ton of other helpful information that can help in diagnosing any hiccups or light build issues.

I’m glad you’ve got everything working for you and you’re happy with your results. :slight_smile:

ok I discovered the problem was me! I took my 4.11 file yesterday night and brought it to the same setting of my 4.10 file: over all I deleted all the light portals and tried to rebuild → it worked! and as you said now it doesn’t give error again! so my 5 portals were so heavy to make a long long (very long) building time! at this time I don’t know if work with portal or overhaul the beselightmass.ini
btw again I’m sorry for all this mess!