No Anti-aliasing when recording with Sequencer...

Any idea why that would be? It happens with or without cinematic mode and scalability checked in the render movie setting. It doesnt seem to matter what my output type is (image, video, etc)

I’ve checked all of the AA and antialias console commands and even have a sequencer event that spits out the AA quality settings in the output window. Theyre all maxed out, but it still looks like there is no AA on the image. Never seen this before from a sequence render.

The rest of the post process settings look good/functional too. Its just AA and only when sequence recording. My view-port and play modes look great.

1 Like

I’m having the same issue. I’ve searched all around and found other people asking but no answers. It takes a week of searching and troubleshooting to find the answer to any little issue in this dumpster software. I guess time to look into cryengine.

same problem here.
very annoying, I tried everything. even rendered out 4 k to scale it down later. but anti aliasing is still an issue.
any one can help?

I have reported very similar problem in 4.22 with the SceneCapture2D component. Basically all postprocessing settings worked except AA, and it required cycling the PostProcessing toggle off and on again in the component for AA to work. There’s probably some issue with initialization of some flag: Unreal Engine Issues and Bug Tracker (UE-79525)

Has there been any news on this? I’m also getting this issue.

Same here. I can’t believe this issue. I have migrated a big project to 4.24 to find this! Sorry but WTF Epic !!!

I am also getting the same issue - trying to pre-vis a car commercial using UE4. But the extremely low quality of the images when you render from the sequencer with jaggies all over the place is killing me. I’m burning days looking up hacks to trigger events from every one of my dozens of level sequences to call console commands to render the images 400% bigger than I need them to blah blah blah.

It would be so much better if the sequencer renders just looked like what I’m seeing in my viewport in the first place. Some kind of over-riding quality settings in the page that comes up when you submit a render would make a lot of sense. Epic, can we please have a response of some kind? Even in the Archvis Raytracing learning example they are doing back-flips, firing off events through blueprint interfaces and all kinds of crazy stuff just to get antialiased images.

I just reviewed a video we made around the time this thread was first posted, and I clearly see AA enabled in it.

We recorded it from the sequencer using 4.22, but we use forward rendering with MSAA, so maybe this thread only applies to deferred with TAA?

+1 . same issue as described. tried all AA types and tried ticking on ‘use selected process’ as I saw somewhere as a suggested solution. no dice though

edit: just turned on ‘Use Path Tracer’ with default 16 pixel sampling and there is improvement however still not great.

posted originally with screenshots here:

attaching path tracing output where image still not resolved [although this particular area isnt either in the viewport, perhaps my raytrace settings arent high enough?]

still better than the original non path traced output.


DanH71 - my images look exactly like your pictures. I just can’t post my own screencaps as the car has not been launched yet.

roberteker - thanks for pitching in, unfortunately I get jaggies from sequencer renders using all three AA methods.

I think a big clue is the fact that, using TemporalAA, I see jaggies as I scrub the timeline live in the editor. But when I stop moving the timeline, the jaggies fade away to resolve to a beautiful picture. My theory is that, being temporal, the AA is accumulating image samples over time in the editor and averaging them together to create the clean images we all want. I think that when you render with sequencer it only fires off one time sample, so no averaging takes place. I can’t find any method to tell the renderer to oversample when writing out a sequence.

Can anyone from Epic please jump in with guidance as to whether this is the case, or instructions on how to achieve the high image quality we see in pieces like Porche: Speed of Light?

DanH71 - After some experimentation this weekend, I’ve found that the preview release of 4.25 (preview 3) has a new feature called the Movie Render Queue (Windows > Cinematics > Movie Render Queue).

There is a hidden setting in there that fixes this problem.

Open the Movie Render Queue window and add your level sequence to it using the “+ Render” button. Now you can go and edit the settings applied to that render. So far so obvious. BUT in the settings window there is another button labelled “+ Setting” and inside there you can optionally choose to add your own anti-aliasing (and other) settings. Why this is an option and hidden away instead of just one comprehensive block of all settings that you can tick on and off like the postprocess volume has I don’t know. Anyway the main thing is that you can go nuts here with temporal and spatial oversampling and it gives great looking renders at last.

Hope that helps.

Shokomin, thank you for sharing this very helpful insight and for detailing the proc as so well!. I will give the 4.25 preview a whirl as soon as possible and can hopefully output some clean images like you have been able to do!

Hey Sokomon,

managed to get a decent render out…

then played with spatial and temporal counts [upping them from default 1 to 12 each] and then a render warmup for TAA at 48 and i got a crash! It warns you that the product of spatial and temporal shouldnt be larger than the TAA samples [but I see no TAA samples displayed to ensure it doesnt] . Any value other than 1 for Saptial/Temporal gives this warning

gonna have to play around and find the sweet spot me thinks without paying the price of loosing all the work id done beforehand again!

thanks for the guide again though.

PS iv’e realised its important to set your frame setting within sequencer to 1 frame to save getting 150 of them everytime;) everything is a bit all over the place in UE4 at times!

EDIT****on closer inspection of my first render with ss 1 and temporal 1 with anti alias on temporal the ouput is still unsatisfactory. If i take ue4s advice and increase these two values I have to disable the anti aliasing and set it to none. But raising these two values gives me strange motion blurred output, as attached.