Download

Niagara particles are blurred when using a material with vertex deformation

Hi,

I’m using a Niagara emitter with a mesh renderer. The mesh uses a material with vertex deformation using World Position Offset.

When the mesh is directly placed in a level, it looks correctly with the vertices moving precisely.
When the mesh is spawned by Niagara instead, the moving vertices appear blurred.

I’ve disabled motion blur on the emitter and also tried to toggle “Output velocities from Vertex Deformation” in the project settings as suggested in 4.20p1 - Niagra Questions/Issues, but nothing changes. It seems the blur can’t be disabled.

Is this a bug or am I missing some configuration?
Thanks for help.

Small update
If I set the motion blur amount to 0 in the PostProcess volume settings, the blur disappears, but I don’t want to remove motion blur completely! I’m just looking on how to disable it on my emitter.