Navmesh Volume not detecting stairs

As demonstrated in the image below, the navmesh bounds volume does not appear to be detecting my stairs. The bounds volume is scaled appropriately, as to encompass the entire level.

Looks like stair mesh doesn’t have a proper collision set. Can you double-check it has identical collision settings to other meshes?



Similar problem with default ThirdPerson level content

My guess is that the stair angle is too steep.

This screenshot doesn’t show a bug. Navmesh cutting trough stairs is a result of navmesh being a simplification of walkable space, not a replication. This is to be expected.

If that was the case then we’d see a navmesh edge where navmesh approaches the stairs. Instead it seems it’s cutting though, that’s why I’m guessing that’s a missing navigation collision.

Right! It’s too late in this part of the world to notice that :stuck_out_tongue:

Well before this, with moving the mesh slightly (less walkable space), the AI was not entering stairs. Though, now it does, but stops close to the end of the upper floor, where there is a small gap in the navmesh (see above image). It is ok now, but a bit weired when not aware that you have to move the navmesh around to get maybe a better result

It’s pretty vague what you say. Maybe you just need to tweak navmesh generation properties?

Not sure if it’s the same cause, but i encountered the same problem.
For me the issue was that it didn’t have simple collision which seems to be used for the navmesh. It had collision but it was only complex collision!
So i simply went into the mesh and changed collision settings from “project default” to “use complex collision as simple

P.S: i know this post is a few years old but i’ll just leave it here if somebody has a similar issue :smiley: