Download

NavMesh not working?

Hey was wondering if anyone knew why this is happening to my level as i have no idea.
As you can see the NavMesh isnt covering all the floor mesh. Ive tried deleting it and starting again but every time i recreate it it comes back with the exact same issues?
The outlined parts dont let my NCP or player run over them?

I have a similar issue with my navmesh… What is strange is that the navmesh settings doesnt seem to match what is actually happening with the navmesh on the level. I tried to delete the recast and navmesh. Then, reapply a new navmesh but it seems like the issue remains. Is there a way of completely reseting the navmesh settings ?

Try changing options through supported agents. General settings often don’t work. Navmesh is indeed very buggy.

I tried playing with the supported agents settings, + tried the recast and navigation mesh project settings (See screenshots).
The problem still persists. I cant seem to find a way to add a full navmesh through doors.navmeshissue30.jpgnavmeshissue1.jpgnavmeshissue2.jpg

I know this is late, but I had the same issue and I hope the next person who needs it can get it.

The fix for my near identical problem was the navmesh was calling for collision against the objects themselves. The actors I had were set to check complex collision, so I had forgotten about it. In the mesh settings of the meshes near the issues I had to go into the editor>collision>Collision complexity and change it to use complex as simple.