Download

NavMesh in (very) small scale

My game’s scale is quite small, like for insects, pawns have about 5 units radius. This leads to issues with the NavMesh, as it seems to support only a min. actor/agent size. With the NavMesh a sample map looks like this:

cd73ce962608728332691bdb41a68fee26b539d7.jpeg

Now I need to get the NavMesh closer to the stones/rocks, I don’t want that much space between them and the mesh bounds. I tried with various NavMesh project settings, even with everything (cell size and height, agent radius, etc.) set to 1.0, but I can’t get that to work.

Can UE4 NavMeshes even handle such a small scale?

I know this is quite old but did you ever find a fix for this?

I have a similar problem, a really small area. When I lower the Nav Agent Radius it marks in green right up the edges on the platform but once it goes lower than “30” my AI character no longer moves.

Anyone got any ideas?

Thanks

Well, I have kind of sorted it out. I didn’t find a real solution, but I played around with the project settings until I found a good solution. I recall though that some settings haven’t been applied until I restarted the UE editor. Maybe that might help you as well?

You can also set the level architecture to not effect Nav mesh generation (sub panel of collision), and then place thin BSPs inside them, to have actors move closer to the boundaries.

Cheers guys. I tried playing with the project settings but that didn’t help. I managed to cobble together what I wanted by making an invisible floor on top of the visible one that was larger to get the boundary to where i wanted it, the “Can ever effect navigation” tick was a useful tip as well, so thanks for that.

Btw i meant Box trigger for alternative nav mesh blocking.

So far i worked with navmeshs, i recognized that they put around a small unused border.
You can see it, where the zone is contacting rocks from outside…
I bet the navmesh is there, but because of size you see only the nongreen navmesh border.
Scaling is always realative to the viewer(bad english sry).
When you scale up the viewdistance in the same way, like the actors you could fix that easy :wink:

You can also change the Navmesh cells inside “Editor - Navmesh”. Though sometimes you can fix navmeshes for stairs when scaling them.