NavMesh in two different levels

Hi there,
I’m using a navmesh in my level for moving (using VR teleport system).
On certain action, the game opens another level (not level streaming).
The navigation works fine in the first level, but once the second is loaded, the navigation doesn’t work. Each time I open the second level in the editor, the recast_navmesh data has disappeared and I have to rebuild the navmesh again. But it doesn’t work either at runtime.
Please note that the pawn used is the same in both levels, so it call the default NavigationQueryFilter through a “Project point to navigation” set as a boolean to validate the move.

Could anybody help me ? Thanks a lot !

the game opens another level (not level streaming).

How exactly do you open your “another level”? And how do you spawn and guarantee persistence of your player pawn (and if you really need it)?

Well, my game has 2 levels. And obviously, the game starts in one.
In the first one, when I hit a key, the blueprint calls an Open Level function, and loads the second one.
In each level I’ve put a Pawn defined by the same blueprint but the functionnalities have to be similar so 2 different versions would be useless imo.

Yes, I meant the same class, sorry :slight_smile:
Unfortunately I can’t pack&share the thing for now. I’ll let you know if I can asap.
In the second level I can’t use the navigation at all : the teleporting system finds no place to teleport from the spawn point. What do you mean by PIE ?

In each level I’ve put a Pawn defined by the same blueprint

It’s not the same pawn then, just of the same class :slight_smile:

Sounds like a navigation setup issue. The project sounds simple enough to pack and share. If you did I’d easily nail down the issue. If not, are you able to use navigation in the second level at all? I mean, is there any case where it works for you (like PIE)?

Hi there,
I didn’t modify my project since last friday, and today the navigation works wel in both levels.
I can’t explain why, but now it works. Thanks, though !

Hi there, I have the problem again…
I’ve made some changes in my game (I added some IA characters walking around, using the same navmesh as the player), and the move is only possible in one of the 2 levels now.
I’ve tried a lot of things (force rebuild on load, dynamic navmesh, using navquery in the player pawn…), but nothing works. Sometimes it works in one level, sometimes in the other.
Has someone an idea ?