Nanite megascans look blurry

When trying to create an environment with nanite assets from megascans, they look blurry. Been trying to follow this youtube tutorial Unreal Engine 5 Beginner Tutorial | Desert Canyons - YouTube but the render i do looks nothing like it. Seems like something is off. Been searching every corner of the internet for the last 6 hours but haven’t found a solution yet. Have anyone got the same issues? Tried with 2 different computers as well.

Check the resolution of your imported textures.
Might have been imported at a lower resolution.

Texture resolution is 8192 x 8192

Here´s a picture from the texture view.

Hmm that is strange indeed.
Try creating a new material and adding the textures manually to see if it makes a difference.
I use the desktop version of bridge and import myself.
So im not sure if it’s something that the plugin does when importing that is messing something up.
edit: just quickly imported one of the sandstone cliff ridges at only 4k resolution at lod0 and it looked fine.

Hi there,

I have the exact same problem :confused:
I am happy to see that I am not the only one that encounter this problem…
For my level design, I am using 3D assets from Megascan, imported with bridge. (nanite quality selected)



I don’t know if the problem is from the material, or the mesh…

the assets of the demo level from Epic looks the same,
Hardware is ok, i9 12900k & 3090
All drivers are updated too

There’s a few different things going on in the different posts.

Those models are about a million tris, sounds like a lot, but that’s not going to hold up from a normal third person view, to an ant view. You still need to be smart about how you are using meshes and understanding how much detail there is, and from what distances they will be viewed from. Often with these demo scenes, small detailed meshes are placed close to the camera, larger less detailed models are placed further away.

Same thing with 8k textures, 8k sounds like a lot, but if you’re zoomed in looking at 1/8th of the model, the texture resolution is only going to hold up on 1080p displays. This is why tiling/detail textures are super important.

Make sure you increase the position precision under nanite settings in the static mesh editor if a model is going to be close to the camera. You can see what resolution nanite is using with auto on the top left of the viewport.

To make sure Quixel Bridge / Megascan models are coming in with full detail, you can disable nanite and check the triangle count.

1 Like


Anyone figure this out yet? I’ve been searching for a couple days and can’t find a solution.

Yeah have the same problem. If i go nanine visualization the colse object got fewer, bigger triangles… so I dont think thats right?

Josh

Yo,
had this issue yesterday- solved it.

The reason why - I’m not sure.
The solution, verify you’re using the right resolutions, build your lighting in “Production” and then you should notice the detail has been built into the project, if it persists you can try baking the material onto the mesh.

i don’t have this issue no more.

also, try rotating or moving your lights or supplying a little more.