Nanite bug causing black spots on mesh

Hello everyone,
I’ve got a bit of catastrophe… I’ve been working on a project for couple of weeks in UE5 with nanite enabled. I’ve changed reflection capture resolution from 128 to 1024 (after watching a youtube video for some other things…) and after restarting UE5 all shaders needed recompiling. When I tried to load a level UE crashed, so I’ve switched back to 128 and after shaders recompiling again I’ve noticed black spots on meshes that are using nanite.
Here’s an example screenshot with a model with nanite enabled and disabled:
Imgur
Imgur
I couldn’t find a fix for this… I’ve imagine because nanite is a new thing not many people had this issue?

Apologies for my poor english, it’s not my first language.

EDIT:
Turning off raytracing shadows seems to fix the issue.

6 Likes

I also encountered the same problem. When static mesh is converted to Nanite, large black blocks of different sizes appear on the surface of the model, but I can’t use normal static mesh because it is a geometry with a high number of meshes. UV distortion will occur when importing UE4, which is very strange, because slight distortion will be found locally when the texture map is viewed from a close distance,

I think the mesh converted to the nanite is reduced, and the shadow of light tracing comes from the reduced mesh, so large black spots are generated. You can find the mesh state of the nanite after being reduced by looking at the UV. However, if we turn off the shadow of light tracing, the effect of the shadow will be very false, because the virtual shadowmap will also have annoying black spots

2 Likes

I am encountering the same issue. Is there anyone who find a way to tweak this issue?

same… this was not fixed in main release

Also, i am converting Megascans assets imported from bridge

For everybody still struggling with this bug try this:

3 Likes