My lighting is completely different in another version

Hey, I have been working on a scene for a while, when I made the scene the file said Other, as what the version said, instead of like 4.7.6.

60373-2.jpg

That’s the version of what it says when I open my Unreal Library, I had a issue trying to install later versions like 4.8 and 4.9. But fixed it. So now to my lighting.

That’s what it looked like in my Other version, nice lighting and smooth. So when I open it, it wont let me open it with Other because I downloaded 4.9, all it say’s it 4.7.6, or open it with 4,9, instead of my ‘Other’ version.

Now when I open the scene, the lighting is completely flat, and theirs static or grain everywhere. The thing is when I delete the post process volume the static goes away, but to make my scene look like what I had before, I need the bias setting, in the post process volume, but when I brighten it, to brighten my scene, it makes it static, I just want my scene to be the same as my other version, which I have no idea where it came from, maybe it couldn’t find a directory and just made it other. I don’t know if it’s because of maybe the post process volume is different in 4.9, and the bias, makes the scene static and grainy now, I have no idea. Any ideas?

-Brian V.

I don’t know if it is another version, but I can’t seem to get rid of this grain and noise in my scene, In my Post Process Volume my noise and grain settings are at 0, I’m not sure why it’s making my scene look like this. Heres a better picture of it. It seems to make the noise when I increase the exposure Bias in the auto exposure settings.

-Brian V.
.

Hey GameMaker02,

I have a few questions which will help me narrow down the cause of this issue.

  • When you upgraded this project’s version, did you ‘Convert in Place’ or did you use the ‘Open a Copy’ option?
  • Would you go into your scenes Post Process Volume and post a screenshot of the settings you have mentioned?
  • Would you provide me with your system specifications/information (dxdiag) and attach them to your response?

We made quite a few changes to Post Processing from versions 4.7 to 4.9 that you might want to take a read over in our Release Notes. Let me know if you have further questions or you discover anything new.

Thank you,

Andrew Hurley

Hey, thanks for getting back to me.

I used, open a copy, and it says 4.9, I still have my other file, which say’s ‘Other’, but won’t let me open it with 4.9, or 4.7. I guess it can’t open because it can’t find my ‘Other’ directory.

My computer is a Mac, OS X Yosemite Version 10.10.5

-Brian Vagie

alt text

Taking up a lot of space, sorry about that. I turn off the Exposure Bias and the statics goes away. The grain and stuff are at 0. Im not sure what it could me, if it’s not the Post Process, maybe it’s something else, I don’t know. Everything is Epic for the settings and everything’s on Production.

One more question, how do I increase my FPS, Frames Per Second. I have 1,000 objects in my scene, (assets) and I’m getting 7 to 8 FPS, thanks.

-Brian Vagie

Hey GameMaker02,

So in order to optimize your projects performance, you are going to need to Profile your CPU and GPU. Since you are using a Mac your Rendering Level is restricted currently to Open GL 3.3+

From this you will need to interpolate between your computers hardware and the various rendering process to optimize what is rendered to the screen at all times. To begin profiling your computers performance for your project, take a look over the documentation we have on Performance and Profiling, CPU Profiling, and GPU Profiling. This should give you enough information to begin optimizing your projects performance.

In line with optimizing your projects performance, you should also take a look over our Post Processing Documentation, but more specifically the Auto-Exposure section. All of this information will help you find the correct look and feel to what you are trying to achieve.

In regards to the odd artifacts however, there is a known and reported issue (UE-21214) with Mac viewport draw errors with certain machines. Here is the original post where it was reported. This could be what you are experiencing and seeing on your own machine. Would you mind providing me with your systems specifications so I can check this against the bug report?

Let me know if you have further questions and I will do my best to assist you further.

Thank you,

Andrew Hurley

This?

Model Name: MacBook Pro
Model Identifier: MacBookPro9,1
Processor Name: Intel Core i7
Processor Speed: 2.6 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 8 GB
Boot ROM Version: MBP91.00D3.B0B
SMC Version (system): 2.1f175

Yea, I don’t understand any of that, I don’t know anything about codes and how to code. Is there a video I can watch to help me with this? Also, are there any settings I can turn up or down, maybe something to increase framerate, like to set my fps settings?

For the post process volume, I’m not sure why I’m getting a weird Artifact, Is there something I can do to fix it on my end?

-Brian V.

Scaling Quality and Profiling your Machine

This should be very helpful to when trying to understand the concepts.

That helped me understand a little better, I’ll fool around with it and try to get better FPS, anyway, what about the artifacts I’m getting in my scene? Anyway to fix that?

I have reported a bug for that issue, and it is still be worked on by the engineers. It has been marked with a high priority so hopefully there is a fix in place soon. For now, a workaround would be to disable Temporal AA and use FXAA instead.

Thanks,

Andrew Hurley

Ok thanks.

-Brian