Motion Controllers don't work (don't track, have no mesh, and no input) [UE5.0.2]

Hi, I’ve created the Template Project and the Motion Controllers don’t work (not tracking, no mesh, no input). I’m using Valve Index and the HMD and Controllers work fine in SteamVR, but in Play-in-Editor only the HMD works, but not the controllers. I’ve tried restarting all sorts of things including the PC, creating a new project, made sure the correct Pawn is selected in the Gamemode and SteamVR is running before opening UE. There are also no errors in the Log that I could go off of. Researching online I haven’t found anything I could try/help troubleshoot. I’m really out of ideas here…

The SteamVR OpenXR runtime is very picky about the app being in focus before binding the controllers. It will not do it if you are not wearing the headset or if the SteamVR dashboard is open. Apart from checking those things, see if other OpenXR applications work properly.

So I before opening UE today I plugged the Index usb cable into another port in my PC (From USB 3.1 Gen1 to USB 3.1 Gen2). Then before opening the project I turned the index on and made sure it wasn’t in standby (put it on my head). Then I opened the project and while still making sure everything was on and in view of base stations clicked on play in editor and (almost) everything works again!
Now I can’t tell if just plugging in the usb into another port was necessary or following your recommendations precisely, or both, but it works, so thanks a lot either way!!

The only problem now is that I get an error message, but hey at least I do now get an error message :slight_smile: :

Blueprint Runtime Error: “Accessed None trying to read property MotionController”. Node: Set LocalGripPosition Graph: GetGrabComponentNearMotionController Function: Get Grab Component Near Motion Controller Blueprint: VRPawn

Fixed the problem, I had removed and added the motion controller components but forgot to bring the references into blueprint again.

I think I have the same problem. The controllers stopped showing in my project. I can restore an old backup but for the life of me I can’t find out what the difference is.

I have a valve index and I’m using UE 5.1. I wich I can find out where this component is.

Were you able to figure this out?

yes. seems that the templet I was using was old. in 5.2 the new temple uses openxr only and it has hands and other things. solved a lot of issues. But I can’t seem to find a way to fix the project I worked on. I tried to copy all the new content of the updated vr templet to the project I was working on. But now the games crash when I teleport around. Looks like I will need to start from scratch.