Modular Building And Lighting

Hey everyone,

First, I want to apologize because I know this has been asked a million times before but I have a question about modular building and lighting. I am not one for building houses and what not so I bought the RealisticHouseKit from the marketplace (pretty great by the way) but I noticed that once I use the directional light, atmospheric fog and all that to “build” my sky, I notice the seams and weird shadows on my walls and floors.

I know this has to do with UV wrapping and changing the lightmass settings can help a little bit but my question is this: When I set a point light or something like that in my scene and set it to dynamic, everything is seamless and looks exactly how you would expect it to so, is there a non performance killing way to emulate the sky and sunlight coming through my windows? I assume that setting every light to dynamic would kill performance.

Also, I am kind of regretting going the route of modular building now that I know all of the issues that UE4 has with it.

Thanks in advance!

" the seams" probably UnitScale/IndirectLighting Settings in the World Settings Lightmaps and seams - Rendering - Unreal Engine Forums

“weird shadows” make sure that there is a production build and a proper UV, and I know that you know it, but first of all you need check this, also check ligtmap resolution of the asset and light channel for UV. In UE you can have perfect realistic scene with a proper world and uv settings Speed level Archviz design : Country House Unreal Engine 4 - YouTube

yes, dynamic light can killing - you can turn off dynamic shadows from all object that shouldn’t receive this, also you can put dynamic lights and objects (which need to have those lights) to different channels (skylight not working with channels), many lods, and spot lights with skybox if possible.

Best way if you use dynamic scene - using hism on your modules, but lighting quality will be not so rich (even with lpv and dfao) as static light if you don’t using RTX of course, but it’s killing too.

Thanks for your answer! I will look into what you recommended. As I fooled around with some things last night, I realized that most of the modular pieces that I was using were simply planes so I set the material to double-sided. This fixed the bleeding that I was having and I doubt that it has to do anything with my lighting issues but I also found out that when I have a point light set, it doesn’t matter if it is static, stationary or moveable; none of them cause seams or any weird artifacts like I thought they were. That only seems to happen when the light from the “sky” hits the walls. What causes this? Why is that the only light source to cause issues? I just find that kind of weird

in normal case - skylight works as supposed.

check this tutors for making good light scene setup and then see results:

  1. Lighting with Unreal Engine Masterclass | Unreal Dev Day Montreal 2017 | Unreal Engine - YouTube
  2. Lighting with Unreal Engine 4 - Episode 14 - Skylight - YouTube
  3. Setting Lighting in Unreal Engine 4.20