MMO Starter Kit

I am having an issue with guild and party commands, all the other chat functions i can chat and whisper other players. My problem is /gcreate <name> is having no response in the chat field. also party invite ques the party invite text to the other player but no party is created after and party chat will not work. has anyone had an issue like this?

have you replaced the db files with the new db files?


In the text bar will teleport you to the player start location

It its a complete clean install of the 4.13 version. I followed all the steps from

I am not running Soruce tho maybe that has something to do with it?

I missed step. 7 in the doc
“Open hostname.ini file located in Chat\ folder with Notepad or other text editor and place the same url as in p.6 there”

Hi, I like the look of this kit and tried to download the test client to have a look, however I’m having some issues getting it to run if anyone can help.
I tried to run the client on my windows 10 rig, the launcher works fine but the downloaded .exe is completely unresponsive, considering an OS issue I then attempted to run it on my windows 7 laptop, I then initially had an issue with missing direct X dll’s which was an easy fix, but it now seems that there is a physx dll missing that I can’t fix.
The dll in question is called “Physx3CommonPROFILE_x64.dll”, the laptop does have a nvidia GPU chip inside it “Geoforce gtx 850m” and an i5 Intel processor, so I know the laptop is capable on running an unreal project build, iv tried to install physx features manually from download and automatically using Geoforce experience which I believe does install physx apart of its drivers.
Any help is apreciated so I can give this a test :slight_smile:

Does this kit allows for servers scaling? Or it’s only work on a single server?

You’ll need to write your own middle layer for that.

Middle? So, a kind of
single-mmo-kit-servermultiple middle-layer serversclients
It just seems weird for me… Or how it should be, basically?

More or less - it really depends on your architecture…

For me it’s node.js servers that are routed via an authority server depending on where the player is.

You will need to do some C++ in the networking layer of the client to modify it to ask the authority server where it should be talking to, then switch to that.

Well I’m exactly asking about suggested architecture when using MMO Starter Kit.
For example, for me it makes more sense in case if MMO Kit becomes a middleware and my custom servers are on the first level: multiple-custom-logic-servers -> multiple-mmo-kit servers -> clients

There are entire books written on which architecture fits your needs… it really depends on what kind of game you have. MMO is not a type of game architecture, it’s a genre. Almost every MMO uses their own snowflake architecture :slight_smile:

That’s why I’m asking about how exactly it could be made with this current MMO Starter Kit. I’m not asking about some kind of “general MMO-game architecture”. Just about current implementation.

Again, it needs to fit your needs based on what you want. You haven’t stated what you want :D. Just trying to help friend. If you want a zone based implementation, yes you’ll need multiple servers that default to different maps, and some middle layer code to transfer the connection between map servers. They need to be pretty much identical except for the default loaded map.

In that case, where is MMO Kit? Does it serve as a “map server”?
If so, it means, it’s designed to work in multiple instances somehow (even if it doesn’t have connections/transfers itself)?

HI ! Can some one help me ? i cant open this project ;/

when i try to change version unity to run it i see:

Running C:/Program Files (x86)/Epic Games/4.13/Engine/Binaries/DotNET/UnrealBuildTool.exe -projectfiles -project=“C:/Users/skava/Documents/My games/Release-1.7/MMOStarterKit-1.7/CleanThirdPerson.uproject” -game -rocket -progress
Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that “Common Tools for Visual C++ 2015” was selected when installing Visual Studio 2015.
Visual C++ 2015 toolchain does not appear to be correctly installed. Please verify that “Common Tools for Visual C++ 2015” was selected when installing Visual Studio 2015.
Discovering modules, targets and source code for project…
UnrealBuildTool Exception: System.Exception: Could not find token at index 0
at fastJSON.JsonParser.NextTokenCore()
at fastJSON.JsonParser.LookAhead()
at fastJSON.JsonParser.ParseValue()
at fastJSON.JsonParser.Decode()
at fastJSON.JSON.Parse(String json)
at UnrealBuildTool.JsonObject.Read(String FileName)
at UnrealBuildTool.PluginDescriptor.FromFile(FileReference FileName)
at UnrealBuildTool.PluginInfo…ctor(FileReference InFile, PluginLoadedFrom InLoadedFrom)
at UnrealBuildTool.Plugins.ReadPluginsFromDirectory(DirectoryReference ParentDirectory, PluginLoadedFrom LoadedFrom)
at UnrealBuildTool.Plugins.ReadProjectPlugins(DirectoryReference ProjectDirectory)
at UnrealBuildTool.RulesCompiler.CreateProjectRulesAssembly(FileReference ProjectFileName)
at UnrealBuildTool.ProjectFileGenerator.AddProjectsForAllTargets(List1 AllGames, ProjectFile& EngineProject, Dictionary2& GameProjects, Dictionary2& ProgramProjects, HashSet1& TemplateGameProjects)
at UnrealBuildTool.ProjectFileGenerator.GenerateProjectFiles(String] Arguments, Boolean& bSuccess)
at UnrealBuildTool.UnrealBuildTool.GenerateProjectFiles(ProjectFileGenerator Generator, String] Arguments)
at UnrealBuildTool.UnrealBuildTool.DoPostStartupStuffThatCanAccessConfigs(String] Arguments)

What i need to do ? what i need to have ?
Where i can find source build UE4 ? i cant find it on GitHub ;/ when i come to link i see error 404 and not found

Hi !

Can someone give new link to source build ue4 ? Is not found on github

can some one give me new link to download source-build UE4 ? on GitHub is not found

Log in Unreal engine account(or creat it if not have).
Settings Your profile and write GITHUB ACCOUNT NAME: “your_github_account_name”… Save. You will receive an e-mail and coud use this link. Epic Games · GitHub

At GitHub you can checkout the source code and then build it your self using Visual Studio

I’ve purchased the MMO Starter Kit, but was wondering if there is a barebones version that only has the login and session handling, not even the persistent world, multiplayer, character, items, etc.

I know that I can just gut the full Starter Kit, but it would be really messy and tedious. Basically, I just want the VA_rest with the login menu, PHP files, and basic login Blueprints.

Thank you!