Download

MMO Starter Kit

Spartan,

Need your help really stuck with an issue. Have revamped the game to handle non target combat which works fine as long as only one player is logged in on the dedicated and built server. Shooting gets messed up, seems like the ignore self on trace stops working. Tried to debug it but not luck. Wanted to validate some basic things with you. When I log into the server it seems like the UserID is not read correct (its in the DB). Is this a real issue on not impacting to the behavior of the server?

[2015.08.20-03.30.58:777][223]LogNet: Login request: /Game/Maps/Start userId: Invalid
[2015.08.20-03.30.58:810][224]LogNet: Client netspeed is 10000
[2015.08.20-03.30.59:704][251]LogNet: Join request: /Game/Maps/Start?SplitscreenCount=1
[2015.08.20-03.30.59:706][251]LogGameMode: levelStatus: /Game/Maps/DollMap 0 0 0 None 0
[2015.08.20-03.30.59:706][251]LogNet: Join succeeded: 256
[2015.08.20-03.31.01:033][291]LogBlueprintUserMessages: Checking entering client, char id:
[2015.08.20-03.31.01:102][294]LogVaRest: Response (200): {“status”:“OK”}
[2015.08.20-03.31.01:102][294]LogBlueprintUserMessages: OK
[2015.08.20-03.31.01:102][294]LogBlueprintUserMessages: create get character
[2015.08.20-03.31.01:169][296]LogVaRest: Response (200): {“status”:“OK”,“name”:“Test1”,“inventory”:],“quests”:],“health”:300,“mana”:200,“level”:0,“experience”
:0,“posx”:4054,“posy”:-3459,“posz”:20366,“rotation_yaw”:-37.411743164062,“equip_head”:"",“equip_chest”:"",“equip_hands”:"",“equip_legs”:"",“equip_feet”:""}
[2015.08.20-03.31.01:170][296]LogBlueprintUserMessages: sending chat login

Yes Tefel. Try downloading the demo server from this link. DEMO SERVER download here If you do that, and it does not work, then try contacting Codespartan in Skype thru chat.

Guys,

Where do you set the resolution options and default settings?

C

Maps DollMap and DesertRallyRace don’t load for me. I only got black loading screen.

First of all, the demo server was down, it’s back online now. :slight_smile:

MrMrC, since you have added significant changes (free-aim combat), I suggest you contact me on Skype (CodeSpartan) so we can discuss it more efficiently.

Thanks! :slight_smile: Positive feedback from active members of the community is something I really appreciate.

Spartan - Thanks for reply. I added you on skype. I actually got this working but have some questions for you as I am starting to run dedicated server tests. Accept me when you get a chance.

I can really recommend buying this. The support offered is great :slight_smile: I have a another question though. I’m trying to setup the modular player as one full persistent model, where the arms, legs, head etc. are empty, unlesss I equip something there so I can have two layers on my model. 1. for the skin underneath the clocthes, and one for the clothes itself. This works fine until I unequip the items, and the player model vanishes. Any ideas about why that is happening? I have also tried creating an extra enum class EquipmentType, called base, where the whole player model is loaded from start, but that also has problems when unequipping. I hope this makes sense… Thank you, and good day :smiley:

I suggest you debug your changes by adding some PrintString nodes in key places to see what’s going on and why the model disappears. I also recommend using some version control (I use regular, non-integrated Git) so you can easily roll back the changes if something breaks.

Hey MMO friends! :slight_smile: I just bought MMO Starter Kit. Unfortunately Current PHP version: 5.4.422.0. So I need to check free hosting before I buy serious one. If You may recommend any fast and stable hosting I will appreciate.
I know PHP, MySQL and I am so excited like a child :))))

Why not just run it localhost with something like xampp?

As myself and CodeSpartan say, you can use x10 hosting, the link is in the documentation. If you’re a little unsure about it, you can select between 5.4 and 5.5 yourself.

Switch themes to cPanel when you’re logged in from here:
be94ba4ab4.png

And scroll down until you see select PHP version:
4d27895778.png

Finally, just select the PHP version, and all should be okay in the tests that CodeSpartan says you should do to test the PHP version:
2a6cc4e770a83a04804b8d1205767b9db9414ed9.png

Just make sure your $servername part of mmoconnection is localhost.

Easy enough really. :slight_smile: Have fun and good luck with the kit!

x10 hosting
Sorry, we’re not able to accept your registration.
We are not currently accepting new users from Poland.

Nice discrimination. Someone can create for me one of that account?

Warwolf can You help me?

First things first, awesome work CodeSpartan, thank you so much for it.

Issue: Having trouble with Listen Server and Client part.

OS: Windows 8.1 Pro

Clean no error build of engine 4.8.1
Switch Unreal Engine version and CleanThirdPerson loads into editor.
Created database on localhost with Mysql, all checks passed and user set up.
(Using localhost database instead of online)
8c613aadf0b135e1bfce339469226f0bf7279079.jpeg

Registration complete
9d4f2fe3a7366ad9271733d2d73212dbe074e1c3.jpeg

Open DesertRallyRace map, check Dedicated server and run game in selected viewport
d301bfc31e5c20da1e11ef1ad261e33391f3aa52.jpeg

Here is where I am having trouble, I update all paths for client and listen server and try to run, screen loads but just sits on Loading Screen forever, also does this in editor with Standalone Game or New Editor Window.
4. loading.jpg

I am seeing no errors and have tried the steps up to here 4 times now with same results, I am pretty sure I am missing something any help or advise would be awesome.

Thank you,
Nemo

HELP ME!

http://wob.c0.pl/mmo/myphpversion.php
http://wob.c0.pl/mmo/mmologin.php

Now i set JSON hostname to http://wob.c0.pl/mmo/

When I hit play and try to create new Account anything happend. When I check database there is no character added. :frowning:

There is no info when I just try to log in but should be “Login information is incorrect…”

It’s not going to work because it’s not pure json. There are ads added.

Like I said before, try using xampp on your own workstation.

I just bought it for 1$ LOL and it WORKS :slight_smile:

Sorry, I don’t know other free hosting providers. I have my own hardware colocated in datacenters.

I seem to have found this error…

Error Accessed None ‘K2Node_DynamicCast_AsLoading_HUD’ from node Set showLoadingScreen in graph ‘EventGraph’ in blueprint LobbyController

cd2f850cca0316cf7fa1b80b0f664776d5551809.jpeg

If it would meet the standard quality levels and being checked by Epic, then he could sell it on the official marketplace. why do you think he does not?

I just realize that my point gravity stopped working when I run dedicated server. It rotates character but he still falling down. Any ideas what can I do?