Download

MMO Starter Kit

you can use both but recommend use the one in doc

I purchased the 4.23 version of the MMO Starter Kit, do I need to pay for each MMO Starter Kit Upgrade or how do I get the 4.24 update?

You’ll always have access to the latest version on Sellfy as long as you haven’t lost your sellfy account.

Good evening @CodeSpartan

Issue #1
I’ve tried about 3 times to upload the game to the ftp.
It does “work” partially, as I can download the game from the launcher, however not the big .pak file.

I also receive this error when uploading (GameUploader) the game, but yet, I can see the file uploaded in the ftp folder.

how can this be fixed? I’ve uploaded two times the build, with the same error.
when I use thelauncher, it will download everything except the pak file, which is 6gb (even though it shows on the ftp folder and is “downloading” the pak from the launcher, as it says the whole game is 6.2gb)

To be honest, I can even download the file from the FTP and it has the same size, as my build before uploading, so it could be uploading successfully (regarding giving that error). Nevertheless, when downloading from launcher there seems to be an issue where that pak file downloads, but does not end up in the game folder (unzip issues? too big? there is no error on this part)

Note: this initially happened in the VPS I set up, then I tried doing it on a webhost (bluehost.com) and happened the same.

PS: i uploaded another project for test, with lots of file no bigger than 10mb and after 20m uploading, same error occured, so its not because of the file size.

Issue #2

No, I have not modified any source, except for the launcher images.
When I do a new “patch” and deploy it, I enter the website.

I noticed this “slash” to be probably wrong?

I ask because it says “deploy successfully” however when I try to download the patch file, it gets stucked. Guess what? Remaining Files: 4
which I believe are these four from the deploy log in the website ftp.

The first upload/deployment is successfully. Then I just open the game, add a new texture, or change a texture in the map (ThirdPerson default), rebuild, open gameuploader, uploads the files, and when I hit the deploy, it always (or the third time) shows these error.

Running deployment
Archives extracted successfully.
Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
-> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_D.m.ubulk.7z
Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
-> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_D.uptnl.7z
Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
-> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_N.m.ubulk.7z
Copying: game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z
-> game/prueba\Content\StarterContent\Textures\T_Wood_Walnut_N.uptnl.7z
ZipSize.xml created successfully.Update deployed successfully.
Back to admin panel

The FTP folder created this new archive, error_log:

[22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267
[22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267
[22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267
[22-Jan-2020 22:22:28 UTC] PHP Warning: copy(game/Engine\Content\EditorMaterials\PreviewShadowIndicator.m.ubulk.7z): failed to open stream: No such file or directory in /home1/ferretg7/public_html/elcom.com/ftp/index.php on line 267

After this error, the launcher just stops working: it would stop at 17% of a download, getting stucked/not downloading anymore. No matter what.

regards

hello Namesis. i might be able to give you some insight here.

Issue #1
I’ve tried about 3 times to upload the game to the ftp.
It does “work” partially, as I can download the game from the launcher, however not the big .pak file.


we ran into this very same issue with out uploader at first. the issue i believe was the path listed for upload.

this is from the documents here: https://docs.google.com/document/d/1…q6-Ix3Eyzs/pub

  1. Go to uploader/ folder, open Settings.ini and fill in the values, for example:

GameDirectory=D:\MyGame\WindowsNoEditor your packaged game folder (no trailing slash)

TempFolder=I: emp a folder to store temp files (no trailing slash)

FtpAddress=ftp://123.123.123.123

FtpLogin=john

FtpPassword=12345

FtpPath=/public_html/launcher/ <— MAKE SURE THIS LINE ENDS IN / OTHERWISE IT WILL NOT BE UPLOADED IN THAT FOLDER AND YOU WILL GET A SECURITY FAIL ENDING THE TRANSFER. AKA. THE UNDERLYING CONNECTION WAS CLOSED. AN UNEXPECTED ERROR OCCURRED ON RECEIVE.

Issue #2

this issue may be resolved if it cannot find the files listed from the above transfer. ensure you have 7zip installed on the patcher system and 7zip files associated with it or it won’t unpack the files correctly. also ensure you have the directory structure manually added. the system will not create the folders on upload or deploy they must be preexisting.

Today marks the 1 year anniversary of purchasing the mmo starter kit. We have come along way in that time. considering there are only 2 of us working on this project im feeling pretty good about our progress. Here is a short video showing some of our project. https://youtu.be/v7yEbf-Eju4

Good News! I have the updated project and have a few issues:

  1. The Documentation mentions adding the address for the PHP files. (Done)

  2. Within the Instance, which isn’t exactly where the documentation mentions there is also a field for the Server Address(?) This confuses me.

  3. The database doesn’t seem to be updated when I run the start without attempting to launch from the Editor which I know is not the process. What might I be doing incorrectly here?

These red guys (bad guys) seem to instantly attack me and I am not able to fight back except to run far away from these guys! Maybe I am missing something else also?

Any insights would be helpful.

I have made some progress. I am still not sure what isn’t working, although I did defeat a couple of bandits and a third killed me! So, I seem to be making some headway forward.

@CodeSpartan

​​​​​​​I downloaded the demo also which worked when I registered a character, which doesn’t work in the project using the start level which as I mentioned earlier I know doesn’t work in editor from start to the Desert Rally Race level. Anyway, I am still curious if the the Server Address in the Instance is needed or if that’s option, I seem to recall it’s needed as I had played it. The other problem has gone away appears anyway which was failing the dedicated server check. (Strange!)

@ IFamStudios - if you followed the install guide and setup your db as per the guide. the only things you should need to do are add the hostname/folder/ path in the mmo instance bp (fig. 1) and set the dedicated server under play. The guide states that you use the start map to create a user account and character but don’t try to enter the main map from there. it is not possible in the editor to go from start to desertrallyrace map. however once the user account is created you can enter play in the desertrallyrace map in editor and it will load the first char (char 0).

@CodeSpartan we decided to prepare moving to the newest version. we rolled the base kit to get it setup and test the chat out. this was the first thing we ran into. any thoughts? I’d like to note the chat server is running and the chat works in the clients when logged in. so this is quite confusing.

@mastermikie @CodeSpartan Both the address and the script url have been added. The problem I have now is the checking of the dedicated server checkbox when running the game outside of editor.

I have seen that previously too! What I couldn’t figure out is what was causing that. My one thought was the Vrest or the tcp plugin not working? @CodeSpartan should be able to answer this for the both of us.

My other issue is here: MMO Starter Kit Errors - Album on Imgur which shows that dedicated server is checked with 1 player and I get the dedicated server not checked error in the external window. Hopefully this will help.

@IFamStudios i believe i know what your issue is here. i believe your attempting to actually launch a game from the “Launch” button. that will not work in this case. If you were building a stand alone game that did not rely on a backend server it would. however with this kit its requires the server component to be running outside the editor. If you want to run outside the editor you will have to run the frontend and cook the client and server. then run the server and start the client with the -local option. The launch will build the client and attempt to connect to the server which wont match the client and additionally wont have the -local option. additonally the only method to get the server built is the frontend.

@mastermikie Thanks, using FrontEnd does make sense! I am not sure if I was using the launch button though, I will definitely build the Front End and will see what happens with that. Right now I am attempting to build a very bare server/client for testing. I haven’t added any skins yet. I haven’t actually had this kit very long since this was a Christmas gift. I am building the front end now and will definitely update you soon.

@IFamStudios i have been working with a partner for just at a year now with the kit. we have come quite a ways in that time. Ofc we were novices ourselves when we started. I am an I.T. manager with nearly 40 years of experience in the field. setting up the servers, c coding and compiling were already in my wheelhouse when we began this. but unreal and the mmo starter kit presented some challenges. we have 1 live server for testers and one private test server for the 2 devs. we have been using the 4.22 kit all this time and are working to move forward with the 4.24 kit. myself i am simply rolling the base kit to ensure we know we have it right before we migrate to it. so likely we may run into the same issues. the community has been fairly good to answer and assist as needed so while i can’t say ill always be able to give you the answer, i will endeavor to pay back the help i received along the way.

@mastermikie Wow! I found the kit awhile ago and decided to purchase this kit when I had the $95.00 to do so, I finally upgraded to 4.24 and the kit is also 4.24. It seems my two problems including yours I have seen in 4.23 before I upgraded. I haven’t been able to reproduce the above error yet in 4.24, although my front end build attempts are failing! Investigating this is not easy. I got my C++ experience playing with IRC and eggdrop bots! back in college where I was studying IT to keep up with the technology, not really for the IT experience although I am able to some IT stuff when necessary.

I too will return the help as I encounter things I can answer too! I am on skype too, not as IFAMStudios I had to shorten the name on here.

@IFamStudios make sure you follow the guide (we refer to is as the bible) very carefully for your front end builds. also are you getting any errors?

Interesting! While the packaging using FrontEnd failed, I was able to package a Windows No Editor which ran, I did an account creation and then attempted to login and that did nothing! I didn’t get any kind of sign, except for the password cleared after doing the account creation.