Missing 'Generate Visual Studio Project Files' in context menu


I’m having issues with getting the ‘Generate Visual Studio Project Files’ to appear and can’t compile my project.

I know there are a few posts on this but I’m sure I have gone through them all and tried all the various solutions several times.

I’ve installed both UE 4.15 & UE 4.12. I’ve tried my hand at several solutions (this post Fix the missing right click menu for Unreal Engine Projects (.uproject) - RoboKiwi.com)
setting the default app ("Generate Visual Studio Project Files" didn't show up - C++ - Epic Developer Community Forums) and other suggestions but I have had no luck.

If I open my Visual Studio project I can see that all the Build commands are pointing to incorrect Unreal location. The project has been copied from another PC which has UE4 in different location.

I cannot find the ‘UnrealVersionSelector’ in the Binaries 64 folder as some have suggested. I have used the Epic Games launcher to install the different versions of Unreal. As I have said, uninstalling all traces of Epic Games and re-installing hasn’t helped. Tried installing the Launcher in different location than x86 but hasn’t helped.

If I use the bat file has shown here ‘Fix the missing right click menu for Unreal Engine Projects (.uproject) - RoboKiwi.com’ I get an ‘Can’t find the Unreal Engine’ error although both 4.15 & 4.12 are installed.

I have also downloaded the source from .git as some have suggested as tried to use the ‘UnrealVersionSelector-Win64-Shipping’ but get an ‘Invalid Command Line’ error. I have tried the various Setup.bat shipped with the source.

As you can see I’ve been trying for awhile to fix this issue had very frustrated to not have my project building in VS. Help on this and any other ideas on what to try would be very, very helpful.

Thank you!


Im having a similar issue. I did install Windows 10 3 days and after that I also reinstalled the epic game laucher. Since then I have no right-click-context menu for .uproject files anymore.

Are you able to compile and launch your project still? I don’t think my project is compiling due to incorrect Visual Studio settings so I’m kinda stuck.

Have you tried some of the fixes dotted around such as the links I posted?

I can compile newly created projects.

Association .uproject / unreal are broken - Content Creation - Unreal Engine Forums. Fixed it by following kenmorechalfant advices.

1 Like

OK thank you to @MadSystem for pointing me in the right direction. Checking out this thread: Association .uproject / unreal are broken - Debugging, Optimization, & Profiling - Epic Developer Community Forums

As suggested in the bottom of the thread I manually copied the ‘UnrealVersionSelector.exe’ from ‘C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64’ to the engine binaries folder: C:\Program Files\Epic Games\UE_4.15\Engine\Binaries\Win64’

Then set the uproject file to associate with the newly placed ‘UnrealVersionSelector’. The right-click menu came back and I can finally rebuild Visual Studio project files. Yay!



Thank you!

I did not copy any files.

I just set the file association of the “.uproject” file to “C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64\UnrealVersionSelector.exe” by following these steps:

  1. right-click the .uproject file
  2. click “open with…”
  3. click “choose another app”
  4. click “more apps”
  5. click “look for another app”
  6. browse to “C:\Program Files (x86)\Epic Games\Launcher\Engine\Binaries\Win64”
  7. select “UnrealVersionSelector.exe”
  8. click “open”
1 Like

Thanks man, it works wonderfully.

thx good!!

Brilliant solution, worked for me – THANK YOU!

Thanks for the solution. Worked here. Thanks!

Thanks for the solution!

Additionally I had to run the newly placed ‘UnrealVersionSelector’ after I set the new association. Then everything worked fine for me, thank you!

1 Like

Hi all, unfortunately this did not fix the issue for me… I’ve also tried manually running UBT on my project in order to generate the project files, but could not see any results from that. Does anyone have any ideas? Thanks in advance.

1 Like

thank u it’s really woking for me

thanks man

Thanks a lot