Missing dynamic shadow

Edit: Follow this post Shadows disappear with increased camera distance - Rendering - Unreal Engine Forums

Change r.Shadow.RadiusThreshold 0.03 to 0.01 and it work perfectly

  • Anyone help me please, Why my scene lack of dynamic shadow for physic actor object ( the balls).
    I use UE4 for making film and animation only. And how to get nice soft shadow of just ambient occlusion on the floor. I try to set skylight to movable but seem nothing happen
  • The video record by Sequencer with default option
  • The following image
  1. Directional light
  2. Lightmass setting
  3. Skylight
  4. Image from video

Bigger balls casting shadow and smaller are not?

This may be related to shadow resolution.

try something from this post

no they are the same size, only cast shadow if the ball near the screen, I try to raise cascade shadow distance but nothing happen

Try settings from link I posted.
Dynamic shadow resolution depends on mesh size and it’s distance from camera.

Thank for your comment
I found this thread. That maybe help

I try to increase setting alot, but still don’t get enough shawdow