Meshes flickers as I pass by (Video included)

I noticed a weird rendering issue I need to fix asap. My meshes flickers as I past by. It looks like as if it’s not rendering quick enough. I’m not even sure if it’s my modular kit meshes or a lighting issue. I have a video included in the link below:
Mesh Flicker UE4 example

1 Like

Thats the occlusion culling. The meshes are poping in and out of the scene as they get occluded, since your camera is moving really fast they are well inside your view before the engine has time to put them there to block your view (hence, you see the sky and fog behind it). If you are using static lightning you can try and play around with the precomputed visibility parameters so its not that agressive.

I am not using any static lighting, just a single moveable stationary light for the whole environment. I don’t want to turn off occlusion culling to avoid performance loss. I tried increasing my bounds which helped a lot. Although I also realized that reduces performance quite a bit as well. I am going to make a first person character blueprint that moves at a walking speed. Maybe the occlusion flicker won’t be noticeable if I turn up the bounds for my static meshes.

Hi Oblivion,

While adjusting the Bounds Scale will help keep the mesh in the scene longer it will hurt performance as you’ve already noticed.

There are two alternatives that can help with this.

  • Create basic geometry outside of the walls that are loading in so that it’s not as noticable. This will block the light from flashing in on screen like this.
  • Secondly, you can use the console command r.HZBOcclusion 1 that will use an approximation based on the size of the mesh for culling.

Using the first method will honestly be the best solution in situations like this where you want to block the light in interior spaces with out as much overhead.

To debug some of the occlusion issues you can also use the console command (Editor only) for r.VisualizeOccludedPrimitives 1 to see the bounds of these meshes when they are occluded vs in scene view.

I hope this helps.


Thanks for tip!