Mesh visibility changes do not apply from blueprints, but they do from editor

I have an NPC character that can cast a teleport ability. He plays a montage that beams him upwards, and I hide his mesh on a notifier. Then when he falls down, I play another montage section, and i display the mesh through a notify as well.

This works flawlessly on a test level. But once i spawn the enemy on a certain level, his mesh does not reappear once it should (or at all) even though his visible variables are properly set (Hidden In Game is false, Visible is true).

Interestingly enough, the only way i have managed to reappear the mesh is by pausing the game, ejecting, and changing ANY property of the mesh through editor’s details window. I could change something totally unrelated, like collision preset, and the mesh would appear again.

Notifiers are both set as ‘Branching point’.
I have checked level blueprint and game mode blueprint for accidentally interfering, and they’re fine.

My assumption is that unreal doesn’t tick visibility for meshes outside of screen space. And once the mesh is inside screen space again, it is not detected.

Solved it by setting a property on skeletal mesh Mesh Component Update Flag to Always Tick Pose and Refresh Bones.