Mesh 'trails' appearing in front of certain materials?

I have just noticed this weird issue in my project, when I move my camera around with the gun in front of a standard opaque default lit material, under certain lighting conditions I get these weird trails of where the gun was previously?
This only happens when the lighting of the background material is a certain way though, when the lighting is brighter than in the picture, like in other areas of my scene, or darker, the trails do not appear? Or at least not visible.

http://i.imgur.com/WU00agE.jpg

PS. You can also see the trails on other things like the temporary ammo counter text renderer in the bottom right.

Hey WarLord,

It seems like you have some ‘Motion Blur’ applied to your scene. In order to fix this visual issue you are experiencing go into the ‘Post Process Volume’ in your level and find the section labeled ‘Motion Blur’.

Post Process Motion Blur

Set the values to 0.0 for both ‘Amount’ and ‘Max’

Hopefully this works for you, but if you still need assistance please let me know.

Cheers,

Andrew Hurley

Yes, no sorry I forgot to mention that I already have motion blur turned off in my post process settings, so that’s not the problem.

Hey WarLord,

No problem. Check your Anti-Aliasing settings and be sure you have ‘Temporal AA’ turned on and the ‘Screen Percentage’ is set to 100.0.

Let me know if this worked for you, or if you need further assistance.

Thank you,

Andrew Hurley

Yes I already had temporal AA on and screen percentage on 100%, so neither of those is the problem?

Check to make sure your Post Process Volume is set to ‘Unbound’ as well. If you would like to see if it is your post processing that is causing the issue, you can toggle it off by using the ‘showFlag.PostProcessing 0’ console command.

If your problem no longer persists, then we can deduce that the issue lies somewhere with your post processing.

Let me know when you have tried this suggestion, and if it was a viable fix for your issue.

Cheers,

Andrew Hurley

Yes my post processing is set to unbound, and there are no other post process actor’s in the scene.

Did you enter the console command as suggested, or have you unchecked the ‘Enabled’ checkbox within your Post Process Volume?

Oh yes, and it did stop the weird effect

So my next suggestion would be to change your Anti-Aliasing to ‘FXAA’ instead of ‘Temporal AA’.

You will loose a small bit of quality, but your edges will be sharper and trails you are seeing should also no longer be apparent. The reason you are seeing the trails is due to how ‘Temporal AA’ gets calculated when applying the method to the screen.

Cheers,

Andrew H

Yes that worked, thankyou :slight_smile:
Are there any plans to fix this issue if it is fixable?

You are welcome. As I mentioned this is not a bug, but just how temporal AA is calculated. There are some console variables you can enter to change some settings for how Temporal AA is calculated.

‘r.TemporalAASamples’ default value is 8 so try reducing it to 4 and see if that does not help your issue as well.

‘r.TemporalAASharpness’ default value is 0. Set this to 1 to increase the sharpness.

Let me know if you have anymore questions or need additional assistance.

Regards,

Andrew Hurley