Mesh throwing 'Overlapping UVs' error

After I build my lights I’m getting the “Overlapping UV’s” error for a mesh that I modeled in blender.

  • I created a second UV channel
  • Unwrapped with light map setting
  • I’ve tried many padding sizes varying
    from 0.0 - 2.0
  • The mesh is triangulated for maximum
  • I have “generate lightmap UVs”
    unticked in UE4 so it uses my second
  • And I’ve remembered to reimport the
    mesh after making changes each time
  • I built lighting with “error
    coloring” and the mesh shows no error
    coloring in lit or unlit as far as I
    can tell

What else could possibly be throwing this error? If it can’t be fixed can I somehow flag that particular mesh only to not show up in the error log?

Thanks in advance.


You can actually view UV1 layout of your mesh in static mesh viewer. Double check that it is imported properly, and there are no overlaps.

Trust me, I’ve double checked everything that is of my current knowledge. I’ve also tried revising the mesh and cleaning it up… removing doubles, deleting loose geometry, rebuild light-map pack etc. but it was already optimized and cleaned up. I also tried enabling “Generate Lightmap UVs” to see if Unreal could handle it but to no avail.

It’s really strange, there doesn’t seem to be any artifacts with lighting (black triangles / splotches) and the error coloring doesn’t show anything either.

I think later I will delete the mesh entirely and reimport from scratch and see if that fixes it. Until then I have it set to ‘movable’ to rid that warning.


Either the uv’s are outside the 0-1 space, overlapped or mirrored (they cannot be mirrored!)

some other stuff:
You dont need to triangulate on export, ue4 does that automatically for you.

In case the mirrored stuff doesnt solve it, show us your uv-map, and a screenshot of the mesh settings.

I’ve included an image. I believe the UVs are never outside the 0-1 space when exclusively letting blender build a lightmap for you. I don’t usually triangulate a mesh before import, I just did that with this mesh after the errors for extra precaution. The UV channel “00” may have mirrored/overlapping UVs but that’s the texture channel, the LM channel, to my knowledge, has none of those things.

channel 0 can have overlaps etc, this should be fine. It is only the Lightmap channel that needs everything error free.

Feel free to email the fbx over to me and i’ll take a quick look if you like.
mclifton at polypusherstudios dot com

Make sure that you’ve got your lightmap coordinate index set to 1. So far, you’ve shown that you’ve set the build settings (for auto-generated lightmap UVs) and that you’re looking at UV 1 for the lightmap UV.

Under the static mesh settings tab you’ll find Lightmap Coordinate Index. This needs to be set to 1 so that it uses the correct UV. The build settings you showed are only used for generation.

There was a bug in 4.13.0 that would allow this to happen. I think this was fixed in 4.13.1 or it may be 4.14, I can’t remember exactly.

You’re not the only one who has fallen victim to this Build Setting. Most who don’t actively use or worry about a lot of the lightmapping intricacies or have custom lightmaps really know or worry about this, so definitely not anything to be embarrassed about. :slight_smile:

Thank you, Tim.
I’m a little embarrassed I was not aware of that setting. Up to this point, none of my other meshes defaulted to channel 0, I’m curious to how that happened.

Thanks to everyone that chimed in too.

Thank you guys so much for this. Newbie here having the same issues and I’m grateful to have found this thread.