Mesh imported fbx from blender appears to be broken and having transperent surfaces. How can I fix this?

Hi, seems to me that you’ve got trouble with your normals in blender.

If your normals are facing the wrong direction, then those mesh parts will not be visible from the outside, but from the inside (cause the normals are facing inside). So in blender make sure that all your normals are facing in the correct direction.

As for the nearly 0 normals, first fix the issue with the normals pointing in the wrong direction, if you then still have this problem maybe try recalculating the normals in blender or maybe try to apply a triangulate modifier and then when you export the mesh check “tangent space”.

Generally speaking getting assets correctly from blender to UE is not easy at first.

In Blender, enable Face Orientation to see what’s wrong. Blue is correct, red is incorrect.

306276-face.png

In Edit Mode, select all faces and press Shift+N. That should fix the normals, but if some are still facing in, flip them manually (select faces, press Alt+N, select Flip).