Mesh Distance Field doesn't work correctly

Hello.
This topic had already been on the forum, but the decision which was given didn’t help, or maybe the problem exists because of the hardware.

During the landscape creation I use water turned on to Generate Mesh Distance Field render.
But when I turn on Global Distance field visualization, the filter shows only the objects without the landscape. According to this, the water is shown in incorrect way, especially foam which must cross with the landscape.



When I open my project on another PC (Radeon RX Vega 56), the asset works well. As for me, I work on a PC with a GTX760.

Reinstalling the engine didn’t help, many variants of settings too.
If the problem is the hardware, which parameters of the video graphic card may influence this? And the main question is: why only landscape has this problem, not props for example. Is it possible to fix it in 4.27?

2 Likes

Unfortunately I don’t know how to solve this problem (or what the hardware limitation might be). But as for why it only affects landscapes, it’s most likely because Landscapes don’t actually generate mesh distance fields, they generate a heightfield that is used instead.

It might be worth reporting as a bug, although I suspect this is a limitation they just never documented (or at least I can’t find any documentation on it)

2 Likes