Megascan trees not casting shadows after building light


I have used some megascan trees in my scene and spreaded them through a foliage. However, once I build my lighting the shadows are gone… How do I fix this?

Before build:

After build:

Hello nxneteen, the warnings seen on your provided image are indicative of a possible LOD concern.

I found a great thread that goes over how to resolve this concern. There are a couple of solutions and instructions posted.

I hope this helps.

As someone suggested in the thread you mentioned, I went to the LOD settings and changed the LOD group from none to foliage, which solved the errors. However, for some reason the trees are still not casting shadows after building the light…


Can you check if the trees are in “Static”?
maybe for some reason they were created in “Movable
(Movable object don’t generate shadow with static lights)

Can you test if create a box in middle of the scene and build lights cast a shadow?
Or maybe try to use another tree to see.

I hope some of this helps you!