Media Texture Resolution Limit?

Hello everyone!

We are looking at doing a project in Unreal where we will be taking 4K/360 footage and putting it in a GearVR app. I’ve been trying to get the media textures to work on my device, but it seems that there is a resolution limit (1920x1080) for the MP4 that we want to use as the movie. Is that true? What if the video is 1920x960? Are there specific resolutions that are required for it to work? Thanks for the help!

Barry Zundel
Villusion Studios, LLC.

In addition to the resolution limit I’ve noticed that media textures seem to have problems with ghosting. Maybe it is the anti-aliasing doing something strange? I’ve tried turning it off but with no improvement. Are there plans to improve the media framework in the future? I know it maybe isn’t as useful for games but for archviz and scientific apps media textures are a big must have. The current implementation seems a bit buggy, and the very strict rule of only allowing windows media file types and no h264 mp4s is a big hassle.

Wow, no love for this thread :slight_smile: Unfortunately we decided to go with Unity for this project because we just can’t get stable or acceptable results from UE4 with the media framework. And we haven’t gotten any responses. It would still be great for the future though, to know if anyone has answers to any of these questions. If someone at epic in the future needs details about the issues we’ve had, we’d love to help improve the media framework! When we get a few more programmer resources we may be able to help with improvements. I’d much rather be doing the work in UE4. :wink:

Hey quality,

We have been working hard to improve upon the Media Framework, and we even removed (very recently) the ability to ‘Stream from Memory’ as this was causing issues with packaged projects. The improvement will be implemented in an upcoming future release.

We are sorry to hear you have moved over to Unity, but we do have another Media Framework feature that can be used as an alternative to the one within the engine. It is an open source VLC media plugin that has stronger video compatibility, but is still in development as well. The issue you mentioned with Ghosting could be unrelated to the Media Player, and more associated with how you are setting up your Post Processing and Materials within your scene. Both of these can have an affect on the overall playback of the video within your scene. If you would like you can create a new AnswerHub post with the issue(s) you are experiencing, provide me with the link in your response to this message, and I will be glad to assist in troubleshooting the issues to help improve upon the feature!

Thank you,

Andrew Hurley

I appreciate the reply. Sorry it took me awhile to get back about this. I started to create a post on the answerhub but then found this post just today that kind of answers the question. It looks like BZundel also already posted on the answer hub here. Looks like 4k video is just not possible currently which is sad :frowning:
We don’t have any post Processing in the scene, just a sphere with a video texture. I’m almost positive that the artifacts we are experiencing are just due to the lack of resolution. We tried importing the footage at its native 4k but it just wouldn’t play back. Even at half res the game fps are way too low to be usable which causes the video to stutter and the lack of resolution makes it a pixelated mess. We’ll just have to wait I guess. Just let them know there at Epic that video playback is a pretty big deal breaker for many of the companies doing VR with UE4.
Thanks again for your response.

Kind regards,

60fps playback of 4K video on GearVR is much needed.

I have to Agree with Quality that video playback is a pretty big deal breaker for many of the companies doing VR with UE4. This needs to be taken very seriously at epic and must get support like yesterday!

I have stuck with Epic all these years and always stuck up for EPIC against unity but now feel like an idiot for doing so because my competitors have a serious advantage over me for doing SO!

Back in November of 2014, Epic promised to make the media player a priority on the forums I feel I was seriously mislead it is now almost a year later and feel the proper attention and support was never given this!! and the excuses we received were amateur and unacceptable when we stuck around waiting while our unity competitors capitalized on this!!!

for over a year now - The Media Framework is not quite production ready yet and is still in the experimental stages. Some features may not work as expected, however we are currently working hard to resolve those issues as well as add addition features and support.

you say you are working hard then we get this!

*Is this still an improvement to look for in 4.8?

gmpreussner gravatar image gmpreussner STAFF May 11 '15 at 12:54 PM
Nope, sorry, I was out of office for three weeks and did not have time to work on this. Pushed to 4.9 now.

devel.bmad gravatar image devel.bmad Jul 13 '15 at 5:37 PM
Great to hear this! Could you please link the commit here for reference? Would this help also with gear VR?

gmpreussner gravatar image gmpreussner STAFF Jul 13 '15 at 5:41 PM
We still haven’t had time to work on this. I’m currently completely backed up with other high priority, and I will be on travel all of next month. Unless someone else can look into it, this won’t happen before September, I’m afraid :/*

Audio is not officially supported yet. There is a prototypical implementation for Windows, but I wouldn’t bet my money on it. Check out the Media Framework Roadmap for upcoming features and improvements.

Media playback in UE4 is becoming more popular lately, but it is by no means a high priority feature as not many developers use it yet. We are currently focusing on other very important Engine features that will affect many more users, but we will also continue to update the media functionality along the way.

Where are the updates??? can we be expecting them in 4.9…can others please reply here so Epic knows this is an important feature for us.

No updates, not even in 4.10. Maybe 4.11…

this is really sad, Unreal. I can’t believe basic stuff like embedding a video texture doesn’t work. Unreal is like that super model girlfriend we all want to date but then have to divorce. soooo pretty. but man. so dumb.

First thing copy your movie file to the content\movies folder in your project. Import the file in UE4… this will create Media Player Asset in the editor…

Open up the new Asset and in the File or URL section reset the URL/file. Next click on the ‘File or URL’ again and add the file you want to play…

Notice that the paths change completely from absolute to relative path.

this will now package correctly and play from any location.


Nice find Jamie. I made it worked a few months back and I didn’t know how. Now it works…it’s all about absolute to relative path.

Hello everybody,
Do you have a solution to read 4K video with the Media Framework in 4.12 ?
And the other framework (VLC) ?

To voice an opinion materials based on compressed index video is not very efficient as to as to maintaining an optimized memory foot print.

A better option would be IFL (Image File List) support which would offer better direct access with no image resolution limitations.


Is there any news on what’s going on with this issue? Is there a ticket for new feature/bug to Epic?

Does this work yet lol

I tried a 4k 60fps movie, and doesnt work… all i got is a black texture i can’t even preview it in the media player

We are try to push a 4k video 4096 x 4096 on GearVr with no luck at all. No news on this from Epic unfortunately. We have this problem from over an year now…
We use samsung s8, s9 and s9+ but there’s no differences…

This problem seems to have not disapear since 2015, how is that possible ?

its 2020, still impossible to render 4096*4096 videos…

2021, checking in. if you have a media texture in a plane, the TAA still does ghosting on it due to “no velocity” on the plane actor…