material/texture is changing with camera distance & affecting shadow quality. I want to disable this and have it constant


I have a translucent material using a mask. All textures have 0 mip maps and yet the texture seems to change resolution with the distance of the camera and I don’t know why. It is ultimately affecting the quality of the shadows it produces every time it changes.

What is happening here? the Mesh is LOD0 so it’s not that, textures have no MipMaps (mask and albedo). Any help please? I need the shadows and the texture coming off of this perforated material to be constantly perfect.

Any help would be highly appreciated. If anyone needs any further screenshots about the texture/material details please let me know.

Thank you in advance. Please find the reference GIF below.

i tried changing mesh material to something else and there was no change as seen in the gif, thats why i thought it had to do with the textures or something in that area.

Hi, looking at your gif, I think what you might actually be seeing is perhaps the infamous Translucency Sorting problem, rather than an LOD issue. The problem seems to be that from certain view angles, it is drawing the closest fence first instead of last. There’s a few things you can try:

  • [Top Recommendation] Try setting the material to “Masked” instead of Translucent (this lowers the performance cost too) and bypasses any issues with future Translucent objects like glass windows. Also makes for nicer shadows.
  • Alternatively: make sure each Translucent plane for the walkway is a separate static Mesh component, and that the pivot for each plane mesh is in the dead-center of the plane. (This is because Unreal uses the pivot location to determine the sort order for Translucent Static Meshes)
  • [Not Recommended] You can hard-code the Translucency Alpha Sort order in the StaticMesh Render Settings:


But I would do this as a last resort only for meshes you are 100% sure are always in front (like HUD elements) or always behind (like distant clouds or water).


Thank you for this, will check it out and report back :slight_smile:

Thank you for the answer, it worked out perfectly fine :slight_smile: