Material light flickering on look.

Hello!

I have a little problem. Made a material with vertex animation, and when I changing the camera axis it starts flickering. But when I moving the character not. Dont know why. Any idea?
Using FXAA, tried different AA, and without it, but same result with each.

Video:

Thanks!
Máté

Hello vmworks,

In order to better understand how exactly you have created this material and how it is being implemented into your project, I would ask you to please post a screenshot of the Material.

Also if you would post a picture of how it is being applied and any settings that you have associated with this Material and Mesh.

I.E post processing, type of AA etc.

Thanks,

Logan

Hello Logan!

The material setup looks like this:

Made the vertex animation with the 3Ds Max script.
The texture is a simple grid, masked out.
Settings:

And just applied on to the mesh.

In a post process volume using FXAA as AA. With no AA a little better, but still pulsing/flickering when I change the players camera.

Thanks for replying!
Máté

Hello vmworks,

Flickering is indicative of mesh distance fields.

1.) Do you have generate mesh distance fields enabled in project settings?
2.) Do you have all dynamic lighting in your scene?
3.) Temporal AA is usually the way to go for these things.
4.) World position offset can sometimes create this issue as well.

These are some of the areas to visit first and troubleshoot.

I would start start with these and look into our documentation on the Wiki and then if you are still experiencing this issue I will look into it further then.

Thanks,

Logan

Hey vmworks,

I haven’t heard from you yet. I was wondering if any of these troubleshoots worked or if you are still experiencing this issue?

Thanks,

Logan

Hello Logan!

Soryy, but I was a little busy.
So, I enabled the mesh distance generation, but it not solved the problem.
I have a directional light source, and a skylight, both set to movable. (That means they are dynamic?)
If I switch in the post process volume to Temporal AA, it stops flickering, but that happens:

Thanks for the advices!
Máté

Hello vmworks,

If you would send me your texture files so I am recreating exactly the material that you have created.

I want to make sure I eliminate as many x factors as possible when recreating a test for this.

Thanks,

Logan

Hello!

Okay, I attach the material, the static mesh, and the textures.

http://we.tl/xKbhRaZGHH

Thank you!
Máté

Hello vmworks,

Thank you for providing what I requested. However, the .uasset’s are project specific. They reference files that are local to your machine.

What I need in order to use these are your content folder, your config folder, and your .uproject.

Thanks,

Logan

Hello vmworks,

I haven’t hard from you in a couple of days. I was wondering if you were still experiencing this issue or had a chance to follow the steps in the previous comment?

Thanks,

Logan

Hello vmworks,

Due to inactivity and tracking purpose I will be marking this thread as answered.

If you are still experiencing this issue please post again and I will continue to address this issue at that time.

Thanks,

Logan

Hello Logan!

Sorry, but I’m at a festival and using this visual game. So now I have not too much time. I’ll be write to you when this project ended. Thanks for your patient, and the help.

Thanks,
Máté

Not a problem have fun!