Download

Massive Light Bleed

Hello
I am trying to make a scene in UE4 for one of my Arch. School projects. I imported one of the main meshes after doing some lightmap work to find this massive bleed in one of the corners. I’ve tried separating the UV, as well as putting them together but nothing works. Any idea on how I can fix this?.

Lightmass settings:
Static Lighting Scale: 0.2
Bounces: 100
Quality: 10
Smoothing: 1.2

Lightmap Res: 1024

http://i.imgur.com/kBVKBSN.png

http://i.imgur.com/GZCoVsx.png

your lightmap UV’s are not very good, it looks like you’re using an automatic method which doesn’t give good results, you can get better coverage and avoid lightmap issues by doing the UV’s by hand. In your case, there’s too many parts that are split up and you’ve got some small parts that shouldn’t be separated out

How would you recommend doing the UV for this project?. Join the interior walls and keep the ceiling and exterior separate?. I’ve watched a couple of videos on youtube on how to do lightmaps, however most of the time the geometry is so simple and the explanations so vague, most times I end up with more questions than answers.

Okay so I redid the light map. I do not know if this is better because most things (shadows) look the same, and the bleed looks the same. The build is a lot faster tho. I also tried to join the UVs that meet in that corner to no avail. Any help or idea is greatly appreciated.

Would you mind sharing the FBX with us?
This looks like a nice unwrapping challenge :slight_smile:

Your Uv-Unwrap is not very good.
Try to learn clean unwrap at a more easy object and i would suggest to stick to quads only first.
KVogler’s offer is nice, but if i would be you, then i would learn on my own.
:slight_smile:

Luftbauch, I like to learn on my own too. But to be honest I do not know what else to do or how else to approach this mesh. KVogler, I do not mind, as long as you show me exactly what you did lol. I will move on with other assets in my scene. Thanks for the help.

Taking KVogler’s offer and having him explain how he went about it IS learning on his own! This is much more helpful to Yojanz than telling him to “learn on his own”.

That is the plan. I just took a look at the model and I think Im gonna make a little “video tutorial”, so you can watch me while I explain.
I already spotted some things that fall in the category “Ok to to if modeling for a still image, but not for gaming”.

While the model (seems) intact, I got some interesting errors when opening it initally :slight_smile:
(But that could be related to the way the FBX was exported)

error.JPG

and thisone made me really raise my eyebrow :stuck_out_tongue:

81a358145dc9aa238f22107d6ffd00c638405f0f.jpeg

But I finally managed to import it “intact”, so tonight Ill have a go at it :slight_smile:

Auto unwrap should work if you break up your walls more. And use high quality lightmass settings.

One lightmap for a whole room is not enough!!! Have a lightmap for each wall, one for the ceiling, one for the floor, etc.

That is true, but wouldn’t that add to the baking time? since you have multiple meshes with high res lightmaps. And a single mesh is more optimized as well no? I could be totally wrong tho.

Hi,

So I remapped the UVs and made a nice video description of what I did and why.
However, i had to discover that my screen recording software only recorded about the first 8 minutes :frowning:
Ill try to put something together that describes the workflow and what I have noticed.

In a nutshell:

  • roof had zero thickness
  • missing faces around the outer door
  • loosely floating faces inside walls (near the roof)

I mapped the roof to the outer walls, kept the ceiings separate, mapped the inner walls as band (the larger tiles twice along the UV space)

But here is the result anyways:

http://s000.tinyupload.com/?file_id=28488640812434834875

Try it with the default 64 lightmap resultion first. :slight_smile:
I dont know about your particular light setup, but I would be surprised if you would need to go beyond 128.

Oh, and I just realized that I forgot to include the Mask texture that I made. Well here it is. Very simple :slight_smile:
Just hook up the materials you need :smiley:

ArchModelMask.jpg

KV, thanks a lot for your unwrap. I think I see what was your intent while unwrapping the mesh and I have a better understanding about it now. Did you get to test it tho? I am afraid I keep getting the same bleeds in the same places.
The lighting setup is exactly the same:
Skylight+Movable Sun(I know the sun does nothing to the indirect)
Static: 0.2 and Production quality lighting build.

http://i.imgur.com/jjMeCP7.png

Have you messed around with your other lightmass settings? In your world settings under lightmass try setting the indirect lighting quality or smoothness up.

Yes, the only settings that get rid of are the default settings (1 static, bounces 3, etc), which are not enough for arch. visualization. I’ve noticed that I get similar bleeds in other areas of my scene where really acute angles occur. I will split the mesh in two through that corner and see what happens.

Aw. I was looking forward to that video. Unwrapping is something I definitely need to learn about!

Ah, Arch Viz, then you need super quality.

Well in the meantime I’d recommend looking at these two links that both deal with lighting for Arch Viz

https://ue4arch.com/ue4archs-unreal-engine-4-lighting-workflow-part-1/

the second link here has alot of trial and error methods so you’ll have to sift through it all to figure out what does what but the first link should help you to start off.

As soon as I find out why the recording software keeps failing, Ill do that :slight_smile:

No problem :slight_smile:
I tested it briefly with some random lights.
But I also had to scale the mesh up because it got imported only 80 units wide :slight_smile:
So, I might have used a different scale as well.

As I said, once I fix my screen recording iisue, Ill have another go at it. :slight_smile:

When nothing else works, the best way to deal with light leaks is to push the light source into nonexistence. Cover your important geometry with external, bogus geometry that will receive that light - the other will receive the shadow.

Though I agree this looks more like bad UV - also, try to cover more area with the walls than what they need to be. I mean, make the walls bigger so they overlap with each other. That way the UV seams and lightmap smoothing won’t affect the result