Main Menu flickers on Unreal Engine

My Main Menu is behaving very weirdly since yesterday. It flickers as soon as I open the menu. Any idea what I could do?



Is it happening only in UE4? Or elsewhere as well. Like chrome, youtube…?

Only UE4! Nowhere else.

Oops! Turns out the problem’s back again after restarting the editor. This time changing the scale settings didn’t work out.

Yes that was the problem! However I’m unsure how this occurred for the first time after using Unreal for almost an year now. I had to change the Scaling mode from Full Panel to Preserve Aspect Ratio for this to work. Can you post this comment as an answer so I can accept it as an answer?

Do you use scaling? Usually that’s the cause of the problem.

Did you play with these settings?


Yes I have the same problem … has anyone solved this?

I didn’t change these settings. However I tried all combinations here after seeing your comment.
No luck.

@Jarrod.Linton Well luckily for me, I had just started with a project and I didn’t make much progress when this started happening. So all I did was create a new project and I migrated my blueprints/assets there. This only happened in that particular project.
But still looking for the root cause of the issue.

Possible workaround for you

  • Go to Editor Preferences → General → Appearence → User Interface
  • Uncheck (if not already) “Enable Window Animations”

That worked for me.

UE 4.25.3 / i5 7400 / GTX 1050TI - Nvidia 452.06 (game ready driver)


thanks, this helps me on macOS big sur.

Disabling high DPI support fixed it on my device.

1 Like


I had the flickering drop-down menus problem (UE 4.25.4 - 4.26.0) running on Windows 7, spreading to a whole screen sometimes. The solution which works for me: Windows Control Panel > All Control Panel Items > System > Advanced system settings > Advanced > Performance > UNCHECK “Enable desktop composition” et voila!
Then you can even enable the windows animation in UE4 Editor Preferences and it will work.

I hope that it will help you too!

1 Like

Thank you very much. It fixes my problem also. :slight_smile:

This fixed it for me. Thank you!!! I actually enabled it the night before looking for another setting.

Sorted…must have ticked it and never noticed…cheers!

This fixed it, thanks

Hey there, that is the exact problem I am having!!! Would love to get some help on this asap!!

I have that exact issue!! Would love some help!!!