Luoshuang's GPULightmass

Yes. I will do it later today I think.

I took a look into it. Looks like it is caused by some mismatch between smoothed shading normal and triangle normal (I tried to replace the chair material with a simple white one and the problem is gone). Currently this is not easy to fix in GPULightmass, so my advice would be try to tessellate your model more (in modeling software, not using material) and see whether it helps.

Maaannnnnnnnn… You are a good maaannnn… :slight_smile: Thanks…

If you have UAC disabled in Windows 10 then it does not work. REG.exe is returning an error when batch is checking the registry info.
The solution then is to create a link for that BAT, move it to the Desktop and run from the Desktop link.

I may have make a mistake somewhere as it should not return an error with UAC disabled. In fact I just tried and it works. Glad you found a workaround. Running the bat file with rightclick “run as administrator” should also work. I tried disabling UAC and found no issues. May try other things tomorrow.

I do not know why (my) Windows treat this script so badly. Then I try to run as a BAT or even Link from Total Commander at batch location then have an error even when run it as an administrator. Just putting the link on the desktop solves problem. But running the REG query from [WINDOWS]->Run->cmd works perfectly.
Maybe my system works so wired :).

same scene with same hdri in 3ds max render

AA.jpg​​​​​​​

Lookd like I have a bug now lol. Would you like to upload the cubemap for me to test?

EDIT: took a second look and it seemed like the sharp shadow are even more dominating in 3ds max?

I can’t seem to get soft shadows, any idea what could be the problem?

The lights above are Spot Lights, with the properties:

  • Source Radius = 6.0
  • Soft Source Radius = 6.0
  • Source Length = 46.

DefaultLightmass.ini:

  • NumPrimaryGISamples=64
  • NumSecondaryGISamples=32

World settings (modified only):

  • Num indirect lighting bounces = 20
  • Num sky light bounces = 10
  • Indirect light quality = 4
  • Indirect smoothness = 0.75
  • Compress lightmaps = false

Lightmap resolution on the ground is very high (red density).

CUDA version 9.2.189. GTX 1070.

Clarification: the image from the post above has 4 spot lights above the table. Here’s a shot with a single point light, with source radius and soft source radius = 4. Still no soft shadows.

Direct lighting from static lights is baked by CPU Lightmass which means they are affected by quality level. Try to set quality level to Production and see what happens.

Oh, that’s right. Changing to production did solve it. Thanks!

Hello all, just download this a few days ago and been grinding at it. really love it. Especially the skylight bounce… produces very good shading.

Now, is there anyways I can utilize more than one gpu from my computer? I have octane (parallel speed increase) and redshift (almost parallel up to two gpus) and they render really fast by utilizing my FOUR gtx 1070s in my pc. It’s a shame that GPU light mass uses only one of my cards…

Can you Luoshuang make any alpha version of multiple gpu version of this GPU lightmass? it really really would be awesome!

anyways, thanks again for this incredible tool. can’t thank you enough.

Kenneth

I did a quick test and the result was different from any version you shown… Will investiagte later

Biggest problem: I have only one GPU and thus cannot perform any test lol

assertion-failed.PNG

Has anyone come across these errors when using GPU lightmass 4.20.2?

I merged the 4.20.2 unified settings zip with the “engine” folder, set the TdrDelay to 300 as recommended, and updated the Nvidia driver to a version >= 398.26 for my GeForce GTX 750 Ti graphics card.

Here are my settings for the baselightmass file

settings.PNG

The errors shown above appear when my lighting build is close to being finished, and the lighting build fails unfortunately.

Is there a workaround for this?

I mean, it looks like you’re out of VRAM…750 Ti only has 2GB I think?

@ Luoshang: As I understand it, this doesn’t support multi-GPU baking (on the same machine), is that still correct?

If I have multiple GPUs on my machine, is it possible to select which one does the baking? (E.g. to use the non-display GPU for baking)

It should be possible by setting environment variable CUDA_VISIBLE_DEVICES. See https://stackoverflow.com/questions/…o-run-a-job-on (not Windows, but should be similar)

EDIT: On Windows looks like we have a more straightforward way: setting it in NVIDIA Control Panel.

You should start a Patreon and maybe that could be sorted out.

I will check it out. Thanks!